码迷,mamicode.com
首页 > 其他好文 > 详细

hdu 3047 Zjnu Stadium

时间:2015-07-29 23:13:31      阅读:364      评论:0      收藏:0      [点我收藏+]

标签:

Zjnu Stadium

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2109    Accepted Submission(s): 808


Problem Description
In 12th Zhejiang College Students Games 2007, there was a new stadium built in Zhejiang Normal University. It was a modern stadium which could hold thousands of people. The audience Seats made a circle. The total number of columns were 300 numbered 1--300, counted clockwise, we assume the number of rows were infinite.
These days, Busoniya want to hold a large-scale theatrical performance in this stadium. There will be N people go there numbered 1--N. Busoniya has Reserved several seats. To make it funny, he makes M requests for these seats: A B X, which means people numbered B must seat clockwise X distance from people numbered A. For example: A is in column 4th and X is 2, then B must in column 6th (6=4+2).
Now your task is to judge weather the request is correct or not. The rule of your judgement is easy: when a new request has conflicts against the foregoing ones then we define it as incorrect, otherwise it is correct. Please find out all the incorrect requests and count them as R.
 

Input
There are many test cases:
For every case:
The first line has two integer N(1<=N<=50,000), M(0<=M<=100,000),separated by a space.
Then M lines follow, each line has 3 integer A(1<=A<=N), B(1<=B<=N), X(0<=X<300) (A!=B), separated by a space.

 

Output
For every case:
Output R, represents the number of incorrect request.
 

Sample Input
10 10 1 2 150 3 4 200 1 5 270 2 6 200 6 5 80 4 7 150 8 9 100 4 8 50 1 7 100 9 2 100
 

Sample Output
2
Hint
Hint:

(PS: the 5th and 10th requests are incorrect)

这是大神的解析,原来是向量的原理:

(1)弄清题意,找出出现冲突的位置,判断冲突很简单就是当两个人在同一行坐,同时他们到根节点的距离差值正好是他们之间的差值,此时就出现了冲突了。

(2)关键有两个地方,这也是并查集题目的难点,就是压缩集合,和求节点到根的距离。这里压缩集合就很简单了,一个通用的递归。求到跟的距离dist[a] += dist[tem]; dist[rb]=dist[a]+x-dist[b];注意这两行代码,这是核心代码,首先第一行是求出节点a到根的距离。第二行代码使用的是数学中向量计算的原理如图

技术分享

#include<stdio.h>
#include<string.h>
#define M 50000+10
int x[M],rank[M];//rank表示的是到根节点的距离 
int find(int k)
{
	int temp=x[k];
	if(x[k]==k) return k;
	x[k]=find(x[k]);
	rank[k]+=rank[temp];
	return x[k];
}
int merge(int a,int b,int m)
{
	int fa=find(a);
	int fb=find(b);
	if(fa==fb){
		if(rank[b]+m!=rank[a])//向量计算 
			return 0;
		else return 1;
	}
	x[fa]=fb;
	rank[fa]=rank[b]+m-rank[a];//用向量的运算法则计算 
	return 1;
}
int main()
{
	int n,m,i,a,b,d;
	while(~scanf("%d%d",&n,&m)){
		for(i=0;i<M;i++){
			x[i]=i; rank[i]=0;
		}
		int count=0;
		while(m--){
			scanf("%d%d%d",&a,&b,&d);
			if(!merge(a,b,d))
				count++;
		}
		printf("%d\n",count);
	}
	return 0;
}



hdu 3047 Zjnu Stadium

标签:

原文地址:http://blog.csdn.net/ling_du/article/details/47133885

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!