码迷,mamicode.com
首页 > 其他好文 > 详细

杭电 HDU 1312 Red and Black(超级简单dfs)

时间:2015-07-31 10:32:51      阅读:85      评论:0      收藏:0      [点我收藏+]

标签:acm   编程   算法   hdu   dfs   

Red and Black

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 12907    Accepted Submission(s): 7983


Problem Description
There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can‘t move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above.
 

Input
The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

‘.‘ - a black tile
‘#‘ - a red tile
‘@‘ - a man on a black tile(appears exactly once in a data set)
 

Output
For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).
 

Sample Input
6 9 ....#. .....# ...... ...... ...... ...... ...... #@...# .#..#. 11 9 .#......... .#.#######. .#.#.....#. .#.#.###.#. .#.#..@#.#. .#.#####.#. .#.......#. .#########. ........... 11 6 ..#..#..#.. ..#..#..#.. ..#..#..### ..#..#..#@. ..#..#..#.. ..#..#..#.. 7 7 ..#.#.. ..#.#.. ###.### ...@... ###.### ..#.#.. ..#.#.. 0 0
 

Sample Output
45 59 6 13
 
#include<iostream>
#include<sstream>
#include<algorithm>
#include<cstdio>
#include<string.h>
#include<cctype>
#include<string>
#include<cmath>
#include<vector>
#include<stack>
#include<queue>
#include<map>
#include<set>
using namespace std;
const int INF=40;
char cnt[INF][INF];
int vis[INF][INF];
int dir[][2]= {{1,0},{0,1},{-1,0},{0,-1}};
int ans,w,h;
void dfs(int x,int y)
{
    for(int i=0; i<4; i++)
    {
        int tx=dir[i][0]+x;
        int ty=dir[i][1]+y;
        if(tx>=1&&tx<=w&&ty>=1&&ty<=h&&!vis[tx][ty]&&cnt[tx][ty]=='.')
        {
            ans++;
            vis[tx][ty]=1;
            dfs(tx,ty);
        }
    }
    return ;
}
int main()
{
    while(cin>>h>>w,h+w)
    {
        memset(vis,0,sizeof(vis));
        int si,sj;
        ans=1;
        for(int i=1; i<=w; i++)
            scanf("%s",cnt[i]+1);

        for(int i=1; i<=w; i++)
        {
            for(int j=1; j<=h; j++)
            {
                if(cnt[i][j]=='@')
                {
                    si=i;
                    sj=j;
                    break;
                }
            }
        }

        dfs(si,sj);
        cout<<ans<<endl;
    }
    return 0 ;
}

版权声明:本文为博主原创文章,未经博主允许不得转载。

杭电 HDU 1312 Red and Black(超级简单dfs)

标签:acm   编程   算法   hdu   dfs   

原文地址:http://blog.csdn.net/lsgqjh/article/details/47166289

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!