码迷,mamicode.com
首页 > 其他好文 > 详细

1064. Complete Binary Search Tree (30)

时间:2015-08-01 01:09:59      阅读:109      评论:0      收藏:0      [点我收藏+]

标签:pat   c++   二叉搜索树   完全二叉树   cbt   

题目如下:

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than the node‘s key.
  • The right subtree of a node contains only nodes with keys greater than or equal to the node‘s key.
  • Both the left and right subtrees must also be binary search trees.

A Complete Binary Tree (CBT) is a tree that is completely filled, with the possible exception of the bottom level, which is filled from left to right.

Now given a sequence of distinct non-negative integer keys, a unique BST can be constructed if it is required that the tree must also be a CBT. You are supposed to output the level order traversal sequence of this BST.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (<=1000). Then N distinct non-negative integer keys are given in the next line. All the numbers in a line are separated by a space and are no greater than 2000.

Output Specification:

For each test case, print in one line the level order traversal sequence of the corresponding complete binary search tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input:
10
1 2 3 4 5 6 7 8 9 0
Sample Output:
6 3 8 1 5 7 9 0 2 4


题目要求对给定的序列建立完全二叉搜索树,所谓完全二叉搜索树就是要满足完全二叉树的搜索树。

我们知道,完全二叉树的结点i如果从1开始编号,那么左儿子为2*i,右儿子为2*i+1;而二叉搜索树的中序遍历为升序,因此只需要对输入序列按照升序排序,然后对完全二叉树进行中序遍历,填入相应的元素即可。

#include <iostream>
#include <vector>
#include <stdio.h>
#include <algorithm>

using namespace std;

vector<int> tree;
vector<int> nodes;
int N;

void buildTree(int root){
    static int index = 1;
    if(root > N) return;
    buildTree(root * 2);
    tree[root] = nodes[index++];
    buildTree(root * 2 + 1);
}

int main()
{
    cin >> N;
    nodes.resize(N+1);
    tree.resize(N+1);
    for(int i = 1; i <= N; i++){
        scanf("%d",&nodes[i]);
    }
    sort(nodes.begin(),nodes.end());
    buildTree(1);
    printf("%d",tree[1]);
    for(int i = 2; i <= N; i++)
        printf(" %d",tree[i]);
    cout << endl;
    return 0;
}

版权声明:本文为博主原创文章,未经博主允许不得转载。

1064. Complete Binary Search Tree (30)

标签:pat   c++   二叉搜索树   完全二叉树   cbt   

原文地址:http://blog.csdn.net/xyt8023y/article/details/47177853

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!