码迷,mamicode.com
首页 > 其他好文 > 详细

Number Sequence

时间:2015-08-01 19:06:53      阅读:99      评论:0      收藏:0      [点我收藏+]

标签:

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 127653    Accepted Submission(s): 31033


Problem Description
A number sequence is defined as follows:

f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.

Given A, B, and n, you are to calculate the value of f(n).
 

Input
The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.
 

Output
For each test case, print the value of f(n) on a single line.
 

Sample Input
1 1 3 1 2 10 0 0 0
 

Sample Output
2 5
#include<stdio.h>
int x[100000000];
int main()
{
	int a,b,n,i,j,k;
	while(scanf("%d%d%d",&a,&b,&n)!=EOF)
	{
		if(a==0&&b==0&&n==0)
		break;
		x[1]=1,x[2]=1;
		for(i=3;i<49;i++)
		x[i]=(a*x[i-1]+b*x[i-2])%7;
		n=n%49;
		printf("%d\n",x[n]);
		
	}
	return 0;
}


版权声明:本文为博主原创文章,未经博主允许不得转载。

Number Sequence

标签:

原文地址:http://blog.csdn.net/l15738519366/article/details/47188269

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!