码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 1237:简单计算器【栈】

时间:2015-08-01 19:09:42      阅读:103      评论:0      收藏:0      [点我收藏+]

标签:   c++   hdu   

简单计算器

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 6429    Accepted Submission(s): 2044

Problem Description
读入一个只包含 +, -, *, / 的非负整数计算表达式,计算该表达式的值。
 

Input
测试输入包含若干测试用例,每个测试用例占一行,每行不超过200个字符,整数和运算符之间用一个空格分隔。没有非法表达式。当一行中只有0时输入结束,相应的结果不要输出。
 

Output
对每个测试用例输出1行,即该表达式的值,精确到小数点后2位。
 

Sample Input
1 + 2 4 + 2 * 5 - 7 / 11 0

Sample Output
3.00 13.36


AC-code:

#include<stdio.h>
#include<stack>
#include<string>
#include<iostream>
using namespace std;
char perc(char a,char c);
double operate(double a,char c,double b);

int main()
{
	double a,b;
	string s;
	char c,theta;
	while(getline(cin,s),s!="0")
	{
		stack<char>fuhao;
		stack<double>zifu;
		int i=0;
		zifu.push(s[i]-48);
		c=s[++i];
		while(c!='\0')
		{
			if(c==' ')
			{
				c=s[++i];
				continue;
			}
			else if(c<='9'&&c>='0')
			{
				if(s[i-1]>='0'&&s[i-1]<='9')//判断是否是非个位数
				{
					a=zifu.top()*10+c-48;
					zifu.pop();
					zifu.push(a);
				}
				else
					zifu.push(c-48);
				c=s[++i];
			}
			else
			{
				if(!fuhao.empty())
				{
					switch(perc(fuhao.top(),c))
					{
						case '<': fuhao.push(c);c=s[++i];break;
						case '>':
							theta=fuhao.top();
							fuhao.pop();
							a=zifu.top();
							zifu.pop();
							b=zifu.top();
							zifu.pop();
							zifu.push(operate(b,theta,a));
							//c=s[++i];注意这里千万不能加上这一句~因为C还没有放进fuhao中
							break;
					}
				}
				else
				{
					fuhao.push(c);
					c=s[++i];
				}
			}
		}
		while(!fuhao.empty())//有可能剩余的有符号
		{
			theta=fuhao.top();
			fuhao.pop();
			a=zifu.top();
			zifu.pop();
			b=zifu.top();
			zifu.pop();
			zifu.push(operate(b,theta,a));
		}
		printf("%.2lf\n",zifu.top());
	}
	return 0;
}
char perc(char a,char c)//判断优先级
{
	if(a=='+'||a=='-')
		switch(c)
		{
			case '+':
			case '-': return '>';break;
			case '*':
			case '/': return '<';break;
		}
	else if(a=='*'||a=='/')
		return '>';
}

double operate(double a,char c,double b)//计算
{
	switch(c)
	{
		case '+': return (a+b);break;
		case '-': return (a-b);break;
		case '*': return a*b;break;
		case '/': return a/b;break;
	}
}


 

版权声明:本文为博主原创文章,未经博主允许不得转载。

HDU 1237:简单计算器【栈】

标签:   c++   hdu   

原文地址:http://blog.csdn.net/lin14543/article/details/47187867

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!