码迷,mamicode.com
首页 > 其他好文 > 详细

HDOJ Holding Bin-Laden Captive! 1085【母函数】

时间:2015-08-03 22:52:56      阅读:159      评论:0      收藏:0      [点我收藏+]

标签:

Holding Bin-Laden Captive!

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 17379    Accepted Submission(s): 7795


Problem Description
We all know that Bin-Laden is a notorious terrorist, and he has disappeared for a long time. But recently, it is reported that he hides in Hang Zhou of China! 
“Oh, God! How terrible! ”

技术分享


Don’t be so afraid, guys. Although he hides in a cave of Hang Zhou, he dares not to go out. Laden is so bored recent years that he fling himself into some math problems, and he said that if anyone can solve his problem, he will give himself up! 
Ha-ha! Obviously, Laden is too proud of his intelligence! But, what is his problem?
“Given some Chinese Coins (硬币) (three kinds-- 1, 2, 5), and their number is num_1, num_2 and num_5 respectively, please output the minimum value that you cannot pay with given coins.”
You, super ACMer, should solve the problem easily, and don’t forget to take $25000000 from Bush!
 

Input
Input contains multiple test cases. Each test case contains 3 positive integers num_1, num_2 and num_5 (0<=num_i<=1000). A test case containing 0 0 0 terminates the input and this test case is not to be processed.
 

Output
Output the minimum positive value that one cannot pay with given coins, one line for one case.
 

Sample Input
1 1 3 0 0 0
 

Sample Output
4
 

Author
lcy
 

Recommend
We have carefully selected several similar problems for you:  1171 2152 2082 1709 2079 
 

题意就是要求找到一个最小的数不能由给定的硬币组成,硬币数量有限制。

#include <stdio.h>
#include <string.h>
#include <algorithm>

using namespace std;

int c1[8100];
int c2[8100];

int generation(int x,int y,int z)
{
	int coin[3]={1,2,5};
	int num[3]={x,y,z};
	int Max=x*1+y*2+z*5;
	memset(c2,0,sizeof(c2));
	memset(c1,0,sizeof(c1));
	for(int i=0;i<=x;i++){
		c1[i]=1;
		//c2[i]=0;
	}
	for(int i=1;i<3;i++){
		for(int j=0;j<=Max;j++){
			for(int k=0;k+j<=Max&&k/coin[i]<=num[i];k+=coin[i]){
				c2[j+k]+=c1[j];
			}
		}
		for(int j=0;j<=Max;j++){
			c1[j]=c2[j];
			c2[j]=0;
		}
	}
	for(int i=0;i<=Max+1;i++){
		if(c1[i]==0)
		return i;
	}
//	return c1[Max];
}

int main()
{
	int x,y,z;
	while(scanf("%d%d%d",&x,&y,&z),x!=0||y!=0||z!=0){
		printf("%d\n",generation(x,y,z));
	}
	return 0;
}


版权声明:本文为博主原创文章,转载请注明出处。

HDOJ Holding Bin-Laden Captive! 1085【母函数】

标签:

原文地址:http://blog.csdn.net/ydd97/article/details/47261977

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!