码迷,mamicode.com
首页 > 其他好文 > 详细

POJ1505 Copying Books(二分法)

时间:2015-08-05 19:53:53      阅读:125      评论:0      收藏:0      [点我收藏+]

标签:

B - 二分
Time Limit:3000MS     Memory Limit:0KB     64bit IO Format:%lld & %llu
 

Description

 

Before the invention of book-printing, it was very hard to make a copy of a book. All the contents had to be re-written by hand by so calledscribers. The scriber had been given a book and after several months he finished its copy. One of the most famous scribers lived in the 15th century and his name was Xaverius Endricus Remius Ontius Xendrianus (Xerox). Anyway, the work was very annoying and boring. And the only way to speed it up was to hire more scribers.

 


Once upon a time, there was a theater ensemble that wanted to play famous Antique Tragedies. The scripts of these plays were divided into many books and actors needed more copies of them, of course. So they hired many scribers to make copies of these books. Imagine you have m books (numbered 技术分享) that may have different number of pages ( 技术分享) and you want to make one copy of each of them. Your task is to divide these books among k scribes, 技术分享. Each book can be assigned to a single scriber only, and every scriber must get a continuous sequence of books. That means, there exists an increasing succession of numbers 技术分享 such that i-th scriber gets a sequence of books with numbers between bi-1+1 and bi. The time needed to make a copy of all the books is determined by the scriber who was assigned the most work. Therefore, our goal is to minimize the maximum number of pages assigned to a single scriber. Your task is to find the optimal assignment.

 

Input 

The input consists of N cases. The first line of the input contains only positive integer N. Then follow the cases. Each case consists of exactly two lines. At the first line, there are two integers m and k技术分享. At the second line, there are integers 技术分享 separated by spaces. All these values are positive and less than 10000000.

 

Output 

For each case, print exactly one line. The line must contain the input succession 技术分享 divided into exactly k parts such that the maximum sum of a single part should be as small as possible. Use the slash character (`/‘) to separate the parts. There must be exactly one space character between any two successive numbers and between the number and the slash.

 


If there is more than one solution, print the one that minimizes the work assigned to the first scriber, then to the second scriber etc. But each scriber must be assigned at least one book.

 

Sample Input 

2
9 3
100 200 300 400 500 600 700 800 900
5 4
100 100 100 100 100

 

Sample Output 

100 200 300 400 500 / 600 700 / 800 900
100 / 100 / 100 / 100 100

 题解:最大值尽量小,让一个包含m个正整数的序列划分成k个非空的连续子序列,是的每个正整数恰好属于一个子序列。设第i个序列的各个数之和为s(i),让所有的是s(i)的最大值尽量小。

每个整数不得超过10的7次方,如果有多解,s(1)应该尽量小,如果仍然有多解,s(2)应该尽量小,依此类推。

解题的关键是找到一个限值,所有的是s(i)均不超过x,从右向左划分,这个x的范围(序列中最大的值~序列所有值的和)

 AC代码:

#include <iostream>
#include <cstring>
using namespace std;
int m,k;
int b[502],f[502];
long long total;
int juge(long long x)
{
    total=1;
    long long sum=0;
    memset(f,0,sizeof(f));
    for(int i=m-1;i>=0;i--)
    {
        sum+=b[i];
        if(sum>x)
        {
            total++;
            sum=b[i];
            f[i]=1;
        }
    }
    return total;
}
int main()
{
    int t;
    long long r,l;
    cin>>t;
    while(t--)
    {
        cin>>m>>k;
        l=r=0;
        for(int i=0; i<m; i++)
        {
            cin>>b[i];
            if(b[i]>l)                      
            {
                l=b[i]; //限值是从序列的最大值到序列所有值的和之间找
            }
            r+=b[i];
        }
        while(l<r)
        {
            int mid=(l+r)/2;
            if(juge(mid)<=k)
                r=mid;
            else
                l=mid+1;
        }
        int total=juge(r);
       // cout<<r;               //输出所找的限值,如过这里对了,基本就过了
        for(int i=0;i<m;i++)
        {
            if(total<k)
                if(!f[i])
                {
                    f[i]=1;
                    total++;
                }
        }
            cout<<b[0];
            for(int i=1;i<m; i++)
            {
                if(f[i-1])  cout<<" /";
                    cout<< <<b[i];
            }
            cout<<endl;
        }
        return 0;
    }

 

POJ1505 Copying Books(二分法)

标签:

原文地址:http://www.cnblogs.com/hfc-xx/p/4705527.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!