码迷,mamicode.com
首页 > 其他好文 > 详细

动态规划 uva 1025

时间:2015-08-07 11:16:34      阅读:130      评论:0      收藏:0      [点我收藏+]

标签:acm   uva   

Secret agent Maria was sent to Algorithms City to carry out an especially dangerous mission. After
several thrilling events we find her in the first station of Algorithms City Metro, examining the time
table. The Algorithms City Metro consists of a single line with trains running both ways, so its time
table is not complicated.
Maria has an appointment with a local spy at the last station of Algorithms City Metro. Maria
knows that a powerful organization is after her. She also knows that while waiting at a station, she is
at great risk of being caught. To hide in a running train is much safer, so she decides to stay in running
trains as much as possible, even if this means traveling backward and forward. Maria needs to know
a schedule with minimal waiting time at the stations that gets her to the last station in time for her
appointment. You must write a program that finds the total waiting time in a best schedule for Maria.
The Algorithms City Metro system has N stations, consecutively numbered from 1 to N. Trains
move in both directions: from the first station to the last station and from the last station back to the
first station. The time required for a train to travel between two consecutive stations is fixed since all
trains move at the same speed. Trains make a very short stop at each station, which you can ignore
for simplicity. Since she is a very fast agent, Maria can always change trains at a station even if the
trains involved stop in that station at the same time.
Input
The input file contains several test cases. Each test case consists of seven lines with information as
follows.
Line 1. The integer N (2 ≤ N ≤ 50), which is the number of stations.
Line 2. The integer T (0 ≤ T ≤ 200), which is the time of the appointment.
Line 3. N ? 1 integers: t1, t2, . . . , tN?1 (1 ≤ ti ≤ 20), representing the travel times for the trains
between two consecutive stations: t1 represents the travel time between the first two stations, t2
the time between the second and the third station, and so on.
Line 4. The integer M1 (1 ≤ M1 ≤ 50), representing the number of trains departing from the first
station.
Line 5. M1 integers: d1, d2, . . . , dM1 (0 ≤ di ≤ 250 and di < di+1), representing the times at which
trains depart from the first station.
Line 6. The integer M2 (1 ≤ M2 ≤ 50), representing the number of trains departing from the N-th
station.
Line 7. M2 integers: e1, e2, . . . , eM2 (0 ≤ ei ≤ 250 and ei < ei+1) representing the times at which
trains depart from the N-th station.
The last case is followed by a line containing a single zero.
Output
For each test case, print a line containing the case number (starting with 1) and an integer representing
the total waiting time in the stations for a best schedule, or the word ‘impossible’ in case Maria is
unable to make the appointment. Use the format of the sample output.
Sample Input
4
55
5 10 15
4
0 5 10 20
4
0 5 10 15
4
18
1 2 3
5
0 3 6 10 12
6
0 3 5 7 12 15
2
30
20
1
20
7
1 3 5 7 11 13 17
0
Sample Output
Case Number 1: 5
Case Number 2: 0
Case Number 3: impossible

//#pragma comment(linker, "/STACK:1024000000,1024000000")
#include<cstdio>
#include<cmath>
#include<stdlib.h>
#include<map>
#include<set>
#include<time.h>
#include<vector>
#include<queue>
#include<string>
#include<string.h>
#include<iostream>
#include<algorithm>
using namespace std;
#define eps 1e-8
#define INF 0x3f3f3f3f
#define LL long long
#define max(a,b) ((a)>(b)?(a):(b))
#define min(a,b) ((a)<(b)?(a):(b))
typedef pair<int , int> P;
#define maxn 55
int n, T, M1, M2;
int t[maxn], m1[maxn], m2[maxn];
int d[205][maxn];
int has[205][maxn][2];
int kase = 0;
void solve()
{
    memset(d, 0x3f, sizeof d);
    d[T][n] = 0;
    for(int i = T - 1; i >= 0; i--)
    {
        for(int j = 1; j <= n; j++)
        {
            d[i][j] = d[i+1][j] + 1;
            if(j < n && has[i][j][0] && i + t[j] <= T)
                d[i][j] = min(d[i][j], d[i + t[j]][j + 1]);
            if(j > 1 && has[i][j][1] && i + t[j-1] <= T)
                d[i][j] = min(d[i][j], d[i + t[j-1]][j-1]);
        }
    }
    printf("Case Number %d: ", ++kase);
    if(d[0][1] >= INF) printf("impossible\n");
    else printf("%d\n", d[0][1]);
}
int main()
{
    //freopen("do.txt", "r", stdin);
    while(~scanf("%d", &n) && n)
    {
        memset(has, 0, sizeof has);
        scanf("%d", &T);
        for(int i = 1; i < n; i++)
        scanf("%d", t + i);

        scanf("%d", &M1);
        for(int i = 1; i <= M1; i++)
        {
            scanf("%d", m1 + i);
            int tmp = m1[i];
            int cnt = 1;
            while(tmp <= T && cnt <= n)
            {
                has[tmp][cnt][0] = 1;

                tmp += t[cnt++];
            }
        }

        scanf("%d", &M2);
        for(int i = 1; i <= M2; i++)
        {
            scanf("%d", m2 + i);
            int tmp = m2[i];
            int cnt = n;
            while(tmp <= T && cnt >= 1)
            {
                has[tmp][cnt][1] = 1;
                tmp += t[--cnt];
            }
        }
        solve();
    }
    return 0;
}
/*
4
55
5 10 15
4
0 5 10 20
4
0 5 10 15
4
18
1 2 3
5
0 3 6 10 12
6
0 3 5 7 12 15
2
30
20
1
20
7
1 3 5 7 11 13 17
0
*/



版权声明:本文为博主原创文章,未经博主允许不得转载。

动态规划 uva 1025

标签:acm   uva   

原文地址:http://blog.csdn.net/dojintian/article/details/47334743

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!