码迷,mamicode.com
首页 > 其他好文 > 详细

hdu3342Legal or Not

时间:2014-07-10 20:15:27      阅读:176      评论:0      收藏:0      [点我收藏+]

标签:des   style   http   java   color   strong   

题目链接:

点我点我

题目:

Legal or Not

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3909    Accepted Submission(s): 1767


Problem Description
ACM-DIY is a large QQ group where many excellent acmers get together. It is so harmonious that just like a big family. Every day,many "holy cows" like HH, hh, AC, ZT, lcc, BF, Qinz and so on chat on-line to exchange their ideas. When someone has questions, many warm-hearted cows like Lost will come to help. Then the one being helped will call Lost "master", and Lost will have a nice "prentice". By and by, there are many pairs of "master and prentice". But then problem occurs: there are too many masters and too many prentices, how can we know whether it is legal or not?

We all know a master can have many prentices and a prentice may have a lot of masters too, it‘s legal. Nevertheless,some cows are not so honest, they hold illegal relationship. Take HH and 3xian for instant, HH is 3xian‘s master and, at the same time, 3xian is HH‘s master,which is quite illegal! To avoid this,please help us to judge whether their relationship is legal or not. 

Please note that the "master and prentice" relation is transitive. It means that if A is B‘s master ans B is C‘s master, then A is C‘s master.
 

Input
The input consists of several test cases. For each case, the first line contains two integers, N (members to be tested) and M (relationships to be tested)(2 <= N, M <= 100). Then M lines follow, each contains a pair of (x, y) which means x is y‘s master and y is x‘s prentice. The input is terminated by N = 0.
TO MAKE IT SIMPLE, we give every one a number (0, 1, 2,..., N-1). We use their numbers instead of their names.
 

Output
For each test case, print in one line the judgement of the messy relationship.
If it is legal, output "YES", otherwise "NO".
 

Sample Input
3 2 0 1 1 2 2 2 0 1 1 0 0 0
 

Sample Output
YES NO
 

Author

这个题目我用了两种方法,先说第一种比较正规的方法吧---拓扑排序。

如果形成一个环,则必然最后会出现所有的点有入度,故在外面判断一下即可。

代码为:

#include<cstdio>
#include<iostream>
#include<cstring>
using namespace std;
const int maxn=100+10;
int map[maxn][maxn],in[maxn];
bool vis[maxn];
int n,m;

void solve()
{
    int cnt=0,i,j,k;
    for(i=0;i<n;i++)
    {
        for(j=0;j<n;j++)
         {
            if(!in[j]&&!vis[j])
            {
                vis[j]=true;
                cnt++;
                for(k=0;k<n;k++)
                {
                    if(map[j][k])
                    {
                        map[j][k]=0;
                        in[k]--;
                    }
                }
                break;
            }
         }
         if(j==n)
         {
             printf("NO\n");
             return;
         }
    }
    if(cnt==n)
        printf("YES\n");
    else
        printf("NO\n");
    return;
}

int main()
{
    int u,v;
    while(~scanf("%d%d",&n,&m),n,m)
    {
        memset(in,0,sizeof(in));
        memset(map,0,sizeof(map));
        memset(vis,false,sizeof(vis));
        for(int i=1;i<=m;i++)
        {
           scanf("%d%d",&u,&v);
           if(!map[u][v])
           {
             map[u][v]=1;
             in[v]++;
           }
        }
        solve();
    }
    return 0;
}

第二种方法是最短路里面的变形,,floyd算法里面的传递闭包。。。这个复杂度很高。。所以跑起来很慢。

代码为:


<pre name="code" class="cpp">#include<cstdio>
#include<cstring>
#include<iostream>
#define INF 0x3f3f3f
using namespace std;
const int maxn=100+10;
int dis[maxn][maxn];
int main()
{
    int n,m,u,v,flag;
    while(~scanf("%d%d",&n,&m),n,m)
    {
        flag=0;
        memset(dis,0,sizeof(dis));
        for(int i=1;i<=m;i++)
        {
            scanf("%d%d",&u,&v);
            dis[u][v]=1;
        }
        for(int k=0;k<n;k++)
            for(int i=0;i<n;i++)
             for(int j=0;j<n;j++)
        {
            dis[i][j]=dis[i][j]||(dis[i][k]&&dis[k][j]);
            //cout<<i<<" "<<j<<" "<<dis[i][j]<<endl;
        }
        for(int i=0;i<n;i++)
            for(int j=0;j<n;j++)
          {
              if(i==j)
                  continue;
              //cout<<dis[i][j]<<" "<<dis[j][i]<<endl;
              if(dis[i][j]&&dis[j][i])
              {
                  flag=1;
                  break;
              }
              if(flag)
                break;
          }
          if(flag)
            printf("NO\n");
          else
            printf("YES\n");
    }
    return 0;
}




hdu3342Legal or Not,布布扣,bubuko.com

hdu3342Legal or Not

标签:des   style   http   java   color   strong   

原文地址:http://blog.csdn.net/u014303647/article/details/37584175

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!