码迷,mamicode.com
首页 > 其他好文 > 详细

Light Bulb

时间:2015-08-08 12:13:18      阅读:166      评论:0      收藏:0      [点我收藏+]

标签:

Light Bulb

Time Limit: 1 Second      Memory Limit: 32768 KB

Compared to wildleopard‘s wealthiness, his brother mildleopard is rather poor. His house is narrow and he has only one light bulb in his house. Every night, he is wandering in his incommodious house, thinking of how to earn more money. One day, he found that the length of his shadow was changing from time to time while walking between the light bulb and the wall of his house. A sudden thought ran through his mind and he wanted to know the maximum length of his shadow.

技术分享

Input

The first line of the input contains an integer T (T <= 100), indicating the number of cases.

Each test case contains three real numbers H, h and D in one line. H is the height of the light bulb while h is the height of mildleopard. D is distance between the light bulb and the wall. All numbers are in range from 10-2 to 103, both inclusive, and H - h >= 10-2.

Output

For each test case, output the maximum length of mildleopard‘s shadow in one line, accurate up to three decimal places..

Sample Input

3
2 1 0.5
2 0.5 3
4 3 4

Sample Output

1.000
0.750
4.000
参考博客:http://blog.csdn.net/pi9nc/article/details/9666627
    http://www.cnblogs.com/kuangbin/archive/2012/09/27/2705751.html
解题思路:人的影子在地面上最大时的点,继续向右走的时候,地面加墙上的影子长度先变大后边小。这好像是常识,凸函数。利用三角形相似计算。x为人到路灯的距离。
大神1解释:根据图,很容易发现当灯,人的头部和墙角成一条直线时(假设此时人站在A点),此时的长度是影子全在地上的最长长度。当人再向右走时,影子开始投影到墙上,当人贴着墙,影子长度即为人的高度。所以当人从A点走到墙,函数是先递增再递减,为凸性函数,所以我们可以用三分法来求解。
大神2代码:
#include<stdio.h>
#include<iostream>
#include<algorithm>
#include<string.h>
#include<math.h>
using namespace std;
const double eps=1e-9;
double D,H,h;


double calc(double x)
{
    return D-x+H-(H-h)*D/x;
}

double solve(double l,double r)
{
    double mid,midmid;
    double d1,d2;
    do
    {
        mid=(l+r)/2;
        midmid=(mid+r)/2;
        d1=calc(mid);
        d2=calc(midmid);
        if(d1>=d2) r=midmid;//这里要注意
        else l=mid;
    }
    while(r-l>=eps);
    return d1;
}
int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%lf%lf%lf",&H,&h,&D);
        printf("%.3lf\n",solve((H-h)*D/H,D));
    }
    return 0;
}

版权声明:本文为博主原创文章,未经博主允许不得转载。

Light Bulb

标签:

原文地址:http://blog.csdn.net/zuguodexiaoguoabc/article/details/47355551

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!