码迷,mamicode.com
首页 > 其他好文 > 详细

poj 1466 Girls and Boys(二分图的最大独立集)

时间:2015-08-10 17:27:03      阅读:127      评论:0      收藏:0      [点我收藏+]

标签:

http://poj.org/problem?id=1466

Girls and Boys
Time Limit: 5000MS   Memory Limit: 10000K
Total Submissions: 11085   Accepted: 4956

Description

In the second year of the university somebody started a study on the romantic relations between the students. The relation "romantically involved" is defined between one girl and one boy. For the study reasons it is necessary to find out the maximum set satisfying the condition: there are no two students in the set who have been "romantically involved". The result of the program is the number of students in such a set.

Input

The input contains several data sets in text format. Each data set represents one set of subjects of the study, with the following description: 
the number of students  the description of each student, in the following format  student_identifier:(number_of_romantic_relations) student_identifier1 student_identifier2 student_identifier3 ...  or  student_identifier:(0) 
The student_identifier is an integer number between 0 and n-1 (n <=500 ), for n subjects.

Output

For each given data set, the program should write to standard output a line containing the result.

Sample Input

7
0: (3) 4 5 6
1: (2) 4 6
2: (0)
3: (0)
4: (2) 0 1
5: (1) 0
6: (2) 0 1
3
0: (2) 1 2
1: (1) 0
2: (1) 0

Sample Output

5
2

最大独立集 = 总点数 - 最大匹配数
因为本题将人数扩大2倍,所以最大匹配数应除以2
技术分享
#include<stdio.h>
#include<string.h>
#include<math.h>
#include<stdlib.h>
#include<algorithm>
#define N 510
#define INF 0x3f3f3f3f

using namespace std;

int G[N][N], vis[N], used[N];
int n;

bool Find(int u)
{
    int i;
    for(i = 0 ; i < n ; i++)
    {
        if(!vis[i] && G[u][i])
        {
            vis[i] = 1;
            if(!used[i] || Find(used[i]))
            {
                used[i] = u;
                return true;
            }
        }
    }
    return false;
}

int main()
{
    int i, a, b, m, ans;
    while(~scanf("%d", &n))
    {
        ans = 0;
        memset(G, 0, sizeof(G));
        for(i = 1 ; i <= n ; i++)
        {
            scanf("%d: (%d)", &a, &m);
            while(m--)
            {
                scanf("%d", &b);
                G[a][b] = 1;
            }
        }
        memset(used, 0, sizeof(used));
        for(i = 0 ; i < n ; i++)
        {
            memset(vis, 0, sizeof(vis));
            if(Find(i))
                ans++;
        }
        printf("%d\n", n - ans / 2);
    }
    return 0;
}
View Code

 

poj 1466 Girls and Boys(二分图的最大独立集)

标签:

原文地址:http://www.cnblogs.com/qq2424260747/p/4718439.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!