码迷,mamicode.com
首页 > 其他好文 > 详细

HDU1503:Advanced Fruits 【LCS】

时间:2015-08-10 22:27:09      阅读:185      评论:0      收藏:0      [点我收藏+]

标签:

Advanced Fruits

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 5   Accepted Submission(s) : 2
Special Judge
Problem Description
The company "21st Century Fruits" has specialized in creating new sorts of fruits by transferring genes from one fruit into the genome of another one. Most times this method doesn‘t work, but sometimes, in very rare cases, a new fruit emerges that tastes like a mixture between both of them.
A big topic of discussion inside the company is "How should the new creations be called?" A mixture between an apple and a pear could be called an apple-pear, of course, but this doesn‘t sound very interesting. The boss finally decides to use the shortest string that contains both names of the original fruits as sub-strings as the new name. For instance, "applear" contains "apple" and "pear" (APPLEar and apPlEAR), and there is no shorter string that has the same property.

A combination of a cranberry and a boysenberry would therefore be called a "boysecranberry" or a "craboysenberry", for example.

Your job is to write a program that computes such a shortest name for a combination of two given fruits. Your algorithm should be efficient, otherwise it is unlikely that it will execute in the alloted time for long fruit names.
 

Input
Each line of the input contains two strings that represent the names of the fruits that should be combined. All names have a maximum length of 100 and only consist of alphabetic characters. Input is terminated by end of file.
 

Output
For each test case, output the shortest name of the resulting fruit on one line. If more than one shortest name is possible, any one is acceptable.
 

Sample Input
apple peach ananas banana pear peach
 

Sample Output
appleach bananas pearch
 

这道题主要是用到了LCS和回溯的方法~~~回溯的时候为了让他们按序输出。。。需要做标记~~~

AC-code:

#include<cstdio>
#include<cstring>
using namespace std;
int mark[105][105];
char s1[105],s2[105];
void print(int a,int b)
{
	if(a==0&&b==0)
		return ;
	else if(a==0)
	{
		print(a,b-1);
		printf("%c",s2[b-1]);
	}
	else if(b==0)
	{
		print(a-1,b);
		printf("%c",s1[a-1]);
	}
	else if(mark[a][b]==1)
	{
		print(a-1,b-1);
		printf("%c",s1[a-1]);
	}
	else if(mark[a][b]==2)
	{
		print(a-1,b);
		printf("%c",s1[a-1]);
	}
	else
	{
		print(a,b-1);
		printf("%c",s2[b-1]);
	}
}
int main()
{
	int len1,len2,i,j;
	int dp[105][105];
	while(~scanf("%s%s",&s1,&s2))
	{
		memset(dp,0,sizeof(dp));
		memset(mark,0,sizeof(mark));
		len1=strlen(s1);
		len2=strlen(s2);
		for(i=1;i<=len1;i++)
			for(j=1;j<=len2;j++)
			{
				if(s1[i-1]==s2[j-1])
				{
					dp[i][j]=dp[i-1][j-1]+1;
					mark[i][j]=1;
				}
				else if(dp[i-1][j]>dp[i][j-1])
				{
					dp[i][j]=dp[i-1][j];
					mark[i][j]=2;	
				}
				else
				{
					dp[i][j]=dp[i][j-1];
					mark[i][j]=3;
				}
			}
		print(len1,len2);
		printf("\n");
	}
	return 0;
}



 

版权声明:本文为博主原创文章,未经博主允许不得转载。

HDU1503:Advanced Fruits 【LCS】

标签:

原文地址:http://blog.csdn.net/lin14543/article/details/47403661

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!