码迷,mamicode.com
首页 > 其他好文 > 详细

poj2051 Argus

时间:2014-07-16 21:27:30      阅读:198      评论:0      收藏:0      [点我收藏+]

标签:des   style   blog   color   os   2014   

Description

A data stream is a real-time, continuous, ordered sequence of items. Some examples include sensor data, Internet traffic, financial tickers, on-line auctions, and transaction logs such as Web usage logs and telephone call records. Likewise, queries over streams run continuously over a period of time and incrementally return new results as new data arrives. For example, a temperature detection system of a factory warehouse may run queries like the following. 
Query-1: "Every five minutes, retrieve the maximum temperature over the past five minutes." 
Query-2: "Return the average temperature measured on each floor over the past 10 minutes."

We have developed a Data Stream Management System called Argus, which processes the queries over the data streams. Users can register queries to the Argus. Argus will keep the queries running over the changing data and return the results to the corresponding user with the desired frequency. 

For the Argus, we use the following instruction to register a query: 
Register Q_num Period

Q_num (0 < Q_num <= 3000) is query ID-number, and Period (0 < Period <= 3000) is the interval between two consecutive returns of the result. After Period seconds of register, the result will be returned for the first time, and after that, the result will be returned every Period seconds. 

Here we have several different queries registered in Argus at once. It is confirmed that all the queries have different Q_num. Your task is to tell the first K queries to return the results. If two or more queries are to return the results at the same time, they will return the results one by one in the ascending order of Q_num. 

Input

The first part of the input are the register instructions to Argus, one instruction per line. You can assume the number of the instructions will not exceed 1000, and all these instructions are executed at the same time. This part is ended with a line of "#". 

The second part is your task. This part contains only one line, which is one positive integer K (<= 10000). 

Output

You should output the Q_num of the first K queries to return the results, one number per line.

Sample Input

Register 2004 200
Register 2005 300
#
5

Sample Output

2004
2005
2004
2004
2005

思路:裸的优先队列题,存起来当模板
/*
 * Author:  Joshua
 * Created Time:  2014年07月10日 星期四 16时10分11秒
 * File Name: poj2501.cpp
 */
#include<cstdio>
#include<queue>

using namespace std;

typedef long long LL;

struct item
{
    int Qnum,period,time;
    bool operator < (const item &a) const
    {
        return time > a.time || (time == a.time && Qnum >a.Qnum);
    }
};

void solve()
{
    priority_queue<item> pq;
    char s[20];

    while (scanf("%s", s ) && s[0]!=#)
    {
        item item;
        scanf("%d%d",&item.Qnum,&item.period);
        item.time=item.period;
        pq.push(item);
    }

    int t;
    scanf("%d",&t);
    while (t--)
    {
        item r = pq.top();
        pq.pop();
        printf("%d\n",r.Qnum);
        r.time +=r.period;
        pq.push(r);
    }
}

int main()
{
    solve();    
    return 0;
}

 

poj2051 Argus,布布扣,bubuko.com

poj2051 Argus

标签:des   style   blog   color   os   2014   

原文地址:http://www.cnblogs.com/code-painter/p/3835990.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!