码迷,mamicode.com
首页 > 其他好文 > 详细

ACM LIS 最长子序列问题

时间:2015-08-13 14:00:37      阅读:161      评论:0      收藏:0      [点我收藏+]

标签:

E - LIS
Time Limit:1000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u
Submit Status

Description

The world financial crisis is quite a subject. Some people are more relaxed while others are quite anxious. John is one of them. He is very concerned about the evolution of the stock exchange. He follows stock prices every day looking for rising trends. Given a sequence of numbers p1, p2,...,pn representing stock prices, a rising trend is a subsequence pi1 < pi2 < ... < pik, with i1 < i2 < ... < ik. John’s problem is to find very quickly the longest rising trend.

Input

Each data set in the file stands for a particular set of stock prices. A data set starts with the length L (L ≤ 100000) of the sequence of numbers, followed by the numbers (a number fits a long integer). 
White spaces can occur freely in the input. The input data are correct and terminate with an end of file.

Output

The program prints the length of the longest rising trend. 
For each set of data the program prints the result to the standard output from the beginning of a line.

Sample Input

6 
5 2 1 4 5 3 
3  
1 1 1 
4 
4 3 2 1

Sample Output

3 
1 
1

Hint

There are three data sets. In the first case, the length L of the sequence is 6. The sequence is 5, 2, 1, 4, 5, 3. The result for the data set is the length of the longest rising trend: 3.
解题思路:
题目的大意是,给定一组数据,让我们求出这组数据的最大上升的序列包含元素的个数。这就是一个求最大子序列的问题。利用二分查找和DP可以解决。
程序代码:
#include <iostream>
#include <cstdio>
using namespace std;
long a[100005];
const int N=100005;
int maxlen(int n,long *list)    //list为序列数组,n为list长度
{
    int len=1,left,mid,right,i,dp[N]={0};
    dp[1]=list[1];
    for(i=2;i<=n;i++)
    {
        left=0,right=len;
        while(left<=right)    //二分查找
        {
            mid=(left+right)/2;
            list[i]>dp[mid] ? left=mid+1 : right=mid-1 ;
        }
        dp[left]=list[i];    //更新dp
        if(left>len)
            len++;    //序列长度+1
    }
    return len;
}
int main()
{
	int n;
    while(~scanf("%d",&n))
    {
        for(int i=1; i<=n; i++)
            scanf("%lld",&a[i]);
        printf("%d\n",maxlen(n,a));
    }
	return 0;
}

  

ACM LIS 最长子序列问题

标签:

原文地址:http://www.cnblogs.com/xinxiangqing/p/4726712.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!