码迷,mamicode.com
首页 > 其他好文 > 详细

poj 2309 BST(数学题)

时间:2014-07-13 11:22:45      阅读:251      评论:0      收藏:0      [点我收藏+]

标签:des   blog   http   使用   strong   os   

BST
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 8440   Accepted: 5093

Description

Consider an infinite full binary search tree (see the figure below), the numbers in the nodes are 1, 2, 3, .... In a subtree whose root node is X, we can get the minimum number in this subtree by repeating going down the left node until the last level, and we can also find the maximum number by going down the right node. Now you are given some queries as "What are the minimum and maximum numbers in the subtree whose root node is X?" Please try to find answers for there queries. 
bubuko.com,布布扣

Input

In the input, the first line contains an integer N, which represents the number of queries. In the next N lines, each contains a number representing a subtree with root number X (1 <= X <= 231 - 1).

Output

There are N lines in total, the i-th of which contains the answer for the i-th query.

Sample Input

2
8
10

Sample Output

1 15
9 11


==================================================================
这题就是Lowbit函数的使用,理解了Lowbit,这题就很容易了
#include <stdio.h>
#include <string.h>
#include <stdlib.h>
#include <algorithm>
#include <math.h>

#define MAxx 1000

int Lowbit(int x)
{
    return x&(-x);
}
int main()
{
    int i,j,n,m;
    scanf("%d",&n);
    for(i=0;i<n;i++)
    {
        scanf("%d",&m);
        int cas=Lowbit(m);
        printf("%d %d\n",m-cas+1,m+cas-1);
    }
    return 0;
}

  

poj 2309 BST(数学题),布布扣,bubuko.com

poj 2309 BST(数学题)

标签:des   blog   http   使用   strong   os   

原文地址:http://www.cnblogs.com/ccccnzb/p/3837742.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!