码迷,mamicode.com
首页 > 其他好文 > 详细

hdu 1071 - The area(解题报告)

时间:2015-08-15 23:08:11      阅读:226      评论:0      收藏:0      [点我收藏+]

标签:math

The area

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 8715    Accepted Submission(s): 6115


Problem Description
Ignatius bought a land last week, but he didn‘t know the area of the land because the land is enclosed by a parabola and a straight line. The picture below shows the area. Now given all the intersectant points shows in the picture, can you tell Ignatius the area of the land?

Note: The point P1 in the picture is the vertex of the parabola.

技术分享

 

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains three intersectant points which shows in the picture, they are given in the order of P1, P2, P3. Each point is described by two floating-point numbers X and Y(0.0<=X,Y<=1000.0).
 

Output
For each test case, you should output the area of the land, the result should be rounded to 2 decimal places.
 

Sample Input
2 5.000000 5.000000 0.000000 0.000000 10.000000 0.000000 10.000000 10.000000 1.000000 1.000000 14.000000 8.222222
 

Sample Output
33.33 40.69
Hint
For float may be not accurate enough, please use double instead of float.
 
参考代码:
#include<stdio.h>  
int main()  
{  
    double x1,x2,x3,y1,y2,y3,a,b,c,k,h,s; 
    int t,i;  
    scanf("%d",&t);  
    while(t--)  
    {  
            scanf("%lf %lf",&x1,&y1);  
            scanf("%lf %lf",&x2,&y2);  
            scanf("%lf %lf",&x3,&y3);  
            a=(y2-y1)/((x2-x1)*(x2-x1));  
            b=-2*a*x1;  
            c=y1-a*x1*x1-b*x1;  
            k=(y2-y3)/(x2-x3);  
            h=y2-k*x2;  
            s=a/3*(x3*x3*x3-x2*x2*x2)+(b-k)/2*(x3*x3-x2*x2)+(c-h)*(x3-x2);  
            printf("%.2lf\n",s);  
    }  
    return 0;  
}  


版权声明:本文为博主原创文章,随便转载。

hdu 1071 - The area(解题报告)

标签:math

原文地址:http://blog.csdn.net/luwhere/article/details/47687055

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!