码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 1014 Uniform Generator

时间:2015-08-16 00:44:16      阅读:72      评论:0      收藏:0      [点我收藏+]

标签:数论

Uniform Generator

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 21845    Accepted Submission(s): 8566


Problem Description
Computer simulations often require random numbers. One way to generate pseudo-random numbers is via a function of the form

seed(x+1) = [seed(x) + STEP] % MOD

where ‘%‘ is the modulus operator. 

Such a function will generate pseudo-random numbers (seed) between 0 and MOD-1. One problem with functions of this form is that they will always generate the same pattern over and over. In order to minimize this effect, selecting the STEP and MOD values carefully can result in a uniform distribution of all values between (and including) 0 and MOD-1. 

For example, if STEP = 3 and MOD = 5, the function will generate the series of pseudo-random numbers 0, 3, 1, 4, 2 in a repeating cycle. In this example, all of the numbers between and including 0 and MOD-1 will be generated every MOD iterations of the function. Note that by the nature of the function to generate the same seed(x+1) every time seed(x) occurs means that if a function will generate all the numbers between 0 and MOD-1, it will generate pseudo-random numbers uniformly with every MOD iterations. 

If STEP = 15 and MOD = 20, the function generates the series 0, 15, 10, 5 (or any other repeating series if the initial seed is other than 0). This is a poor selection of STEP and MOD because no initial seed will generate all of the numbers from 0 and MOD-1. 

Your program will determine if choices of STEP and MOD will generate a uniform distribution of pseudo-random numbers. 
 

Input
Each line of input will contain a pair of integers for STEP and MOD in that order (1 <= STEP, MOD <= 100000).
 

Output
For each line of input, your program should print the STEP value right- justified in columns 1 through 10, the MOD value right-justified in columns 11 through 20 and either "Good Choice" or "Bad Choice" left-justified starting in column 25. The "Good Choice" message should be printed when the selection of STEP and MOD will generate all the numbers between and including 0 and MOD-1 when MOD numbers are generated. Otherwise, your program should print the message "Bad Choice". After each output test set, your program should print exactly one blank line.
 

Sample Input
3 5 15 20 63923 99999
 

Sample Output
3 5 Good Choice 15 20 Bad Choice 63923 99999 Good Choice
 

Source
 

Recommend
JGShining


此题巨水,但是有坑。

第一个坑人的地方:英文题,文字太多,让人一看就不想做,并且题目的意思也有点难以理解。

第二个坑从样例的输出就可以看出,超麻烦的样子,一个不小心就PE了,还得数空格……+_+


废话不多说,总之很坑╮(╯▽╰)╭。回归正题……

题目意思就是说,给出两个数,要你判断这两个数是否互质,如果互质则是“Good Choice”,否则为“Bad choice”,只不过输出的格式很坑爹,各种空格,PE了几次才过。。。

每个数字占10列,数字与字符之间有4个空格)……


/*
Author:ZXPxx
Memory: 1600 KB		Time: 0 MS
Language: C++		Result: Accepted
*/

#include <cstdio>

int gcd(int a, int b) {
    return !b ? a:gcd(b,a%b);
}
int main(){
    char str[2][15] = {"Bad Choice", "Good Choice"};
    int a,b;
    while(~scanf ("%d%d", &a, &b))
        printf ("%10d%10d    %s\n\n", a, b, str[gcd(a,b)==1]);
    return 0;
}



版权声明:本文为博主原创文章,未经博主允许不得转载。

HDU 1014 Uniform Generator

标签:数论

原文地址:http://blog.csdn.net/zhang_xueping/article/details/47689179

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!