码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 1796 How many integers can you find

时间:2015-08-16 10:49:13      阅读:137      评论:0      收藏:0      [点我收藏+]

标签:数论   容斥原理   dfs   

How many integers can you find

Time Limit: 12000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 5517    Accepted Submission(s): 1580


Problem Description
  Now you get a number N, and a M-integers set, you should find out how many integers which are small than N, that they can divided exactly by any integers in the set. For example, N=12, and M-integer set is {2,3}, so there is another set {2,3,4,6,8,9,10}, all the integers of the set can be divided exactly by 2 or 3. As a result, you just output the number 7.
 

Input
  There are a lot of cases. For each case, the first line contains two integers N and M. The follow line contains the M integers, and all of them are different from each other. 0<N<2^31,0<M<=10, and the M integer are non-negative and won’t exceed 20.
 

Output
  For each case, output the number.
 

Sample Input
12 2 2 3
 

Sample Output
7
 

Author
wangye
 

Source
 

Recommend
wangye
 
题目意思是给出数n和一个包含m个数的集合,要求的是小于n,且是集合内任意元素的倍数的数有多少。(有点绕,多读两遍就理解了)。
这个题目要用到的原理是容斥原理,什么是容斥原理呢?大概学过集合或者概率论的都知道吧!
容斥原理:先不考虑重叠的情况,把包含于某内容中的所有对象的数目先计算出来,然后再把计数时重复计算的数目排斥出去,使得计算的结果既无遗漏又无重复。
技术分享

本题的关键是要如何实现容斥原理,最简单的就是直接暴力,数据比较水能过,还有一种方法就是用dfs优化。
两种方法均可,只是时间复杂度的大小问题。
此题还有一点点小坑,稍不细心的人就可能掉进去(比如我……T_T……),集合中元素可能包含0,要先筛选一遍才能操作……不多说了,直接上代码:

/*
Author:ZXPxx
Memory: 1616 KB		Time: 202 MS
Language: C++		Result: Accepted
*/

#include <algorithm>
#include <iostream>
#include <cstring>
#include <cstdlib>
#include <cstdio>
#include <string>
#include <vector>
#include <cmath>
#include <ctime>
#include <queue>
#include <stack>
#include <set>
#include <map>
using namespace std;
typedef long long LL;
const int maxn = 5e5 + 5;
const int inf = 0x3f3f3f3f;

int a[130],n,m,ans,p,cur;
int gcd(int a,int b) {
    return !b ? a:gcd(b,a%b);
}
int lcm(int a,int b) {
    return a/gcd(a,b)*b;
}
void dfs(int i,int flag,int k)
{
    k=lcm(a[i],k);
    ans+=n/(k*flag);
    for(int j=i+1;j<cur;j++)
        dfs(j,-flag,k);
}
int main() {
    while(~scanf("%d %d",&n,&m)) {
        cur=0;
        for(int i=0; i<m; i++) {
            scanf("%d",&p);
            if(p)
                a[cur++]=p;
        }
        ans=0;n--;
        for(int i=0; i < cur; i++) {
            dfs(i,1,a[i]);
        }
        printf("%d\n",ans);
    }
    return 0;
}



爆搜的代码也来一发。。。

/*
Author:ZXPxx
Memory: 1648 KB		Time: 998 MS
Language: C++		Result: Accepted
*/

#include <algorithm>
#include <iostream>
#include <cstring>
#include <cstdlib>
#include <cstdio>
#include <string>
#include <vector>
#include <cmath>
#include <ctime>
#include <queue>
#include <stack>
#include <set>
#include <map>
using namespace std;
typedef long long LL;
const int maxn = 5e5 + 5;
const int inf = 0x3f3f3f3f;

int a[130],m,n,p,cur,ans;
int gcd(int a,int b) {
    return !b ? a:gcd(b,a%b);
}
int lcm(int a,int b) {
    return a/gcd(a,b)*b;
}
int main() {
    while(~scanf("%d %d",&n,&m)) {
        n--;    cur=0;     ans=0;
        for(int i=0; i<m; i++) {
            scanf("%d",&p);
            if(p)  a[cur++]=p;
        }
        for(int i= 1;i < pow(2,cur); i++) {
            int cnt=0,flag=0,k=1;
            for(int j = 0; j < cur; j++) {
                if(i>>j & 1) {
                    k=lcm(k,a[j]);
                    if(k>n) {
                        flag=1;
                        break;
                    }
                    cnt++;
                }
            }
            if(flag) continue;
            if(cnt%2)
                ans+=n/k;
            else
                ans-=n/k;
        }
        printf("%d\n",ans);
    }
    return 0;
}



版权声明:本文为博主原创文章,未经博主允许不得转载。

HDU 1796 How many integers can you find

标签:数论   容斥原理   dfs   

原文地址:http://blog.csdn.net/zhang_xueping/article/details/47699787

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!