码迷,mamicode.com
首页 > 其他好文 > 详细

NBUT 1225 NEW RDSP MODE I (规律+快速幂)

时间:2015-08-18 11:29:04      阅读:239      评论:0      收藏:0      [点我收藏+]

标签:

  • [1225] NEW RDSP MODE I

  • 时间限制: 1000 ms 内存限制: 131072 K
  • 问题描述 
  •  

     

    Little A has became fascinated with the game Dota recently, but he is not a good player. In all the modes, the rdsp Mode is popular on online, in this mode, little A always loses games if he gets strange heroes, because, the heroes are distributed randomly.

     

    Little A wants to win the game, so he cracks the code of the rdsp mode with his talent on programming. The following description is about the rdsp mode:

     

    There are N heroes in the game, and they all have a unique number between 1 and N. At the beginning of game, all heroes will be sorted by the number in ascending order. So, all heroes form a sequence One.

     

    These heroes will be operated by the following stages M times:

     

    1.Get out the heroes in odd position of sequence One to form a new sequence Two;

     

    2.Let the remaining heroes in even position to form a new sequence Three;

     

    3.Add the sequence Two to the back of sequence Three to form a new sequence One.

     

    After M times‘ operation, the X heroes in the front of new sequence One will be chosen to be Little A‘s heroes. The problem for you is to tell little A the numbers of his heroes.

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

     

  • 输入
  • There are several test cases.
    Each case contains three integers N (1<=N<1,000,000), M (1<=M<100,000,000), X(1<=X<=20).
    Proceed to the end of file.
  • 输出
  • For each test case, output X integers indicate the number of heroes. There is a space between two numbers. The output of one test case occupied exactly one line.
  • 样例输入
  • 5 1 2
    5 2 2
  • 样例输出
  • 2 4
    4 3
  • 提示
  • In case two: N=5,M=2,X=2,the initial sequence One is 1,2,3,4,5.After the first operation, the sequence One
    is 2,4,1,3,5. After the second operation, the sequence One is 4,3,2,1,5.So,output 4 3.
  • 来源
  • 辽宁省赛2010

题意:1~N个数字组成数组A,将数组中奇数位组成一个数组B,偶数位组成一个数组C,然后将B连接到C后面,求执行M次,输出最后的前X位数。

分析:这道题可以理解成求一个数在M次变换之后最后的位置,那么首先就从两次变换的关系开始推导

假设本次的位置为X,分为偶数和奇数两种情况:

如果X为偶数,那么X下一次的坐标就会是X‘=X/2,可以理解成前面有一半的奇数被拿走了,变换一下 X=2*X‘

如果X为奇数,那么X下一次的坐标就会是X‘=N/2+X/2,可以理解成前面有N/2个偶数,然后还有X/2个奇数排在X前面,变换一下 X=2*X‘ - N

可以发现,无论是奇数还是偶数,都是 X=2*X 之后对N取模,那么经过M次变换可以看成2的M次幂,这里写一个快速幂就行了。

还要注意,当N为偶数的时候要+1,因为N为偶数的时候,取模后下标可能为0,当N为奇数时,第N位数在变换中位置是不变的,所以情况和N-1一样。

技术分享
#pragma comment(linker, "/STACK:1024000000,1024000000")
#include<cstdio>
#include<string>
#include<iostream>
#include<cstring>
#include<cmath>
#include<stack>
#include<queue>
#include<vector>
#include<map>
#include<stdlib.h>
#include<algorithm>
#define LL __int64
#define FIN freopen("in.txt","r",stdin)
using namespace std;
LL N,M,X;
LL ans,tmp;
LL pow(LL x,LL n,LL MOD)
{
    LL res=1;
    while(n)
    {
        if(n&1) res=(x*res)%MOD;
        x=(x*x)%MOD;
        n>>=1;
    }
    return res;
}
int main()
{
    while(scanf("%I64d %I64d %I64d",&N,&M,&X)!=EOF)
    {
        if(N%2==0) N++;
        tmp=pow(2,M,N);
        ans=tmp;
        printf("%I64d",tmp);
        for(int i=2;i<=X;i++)
        {
            ans+=tmp;
            ans%=N;
            printf(" %I64d",ans);
        }
        printf("\n");
    }
    return 0;
}
View Code

 

NBUT 1225 NEW RDSP MODE I (规律+快速幂)

标签:

原文地址:http://www.cnblogs.com/clliff/p/4738703.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!