码迷,mamicode.com
首页 > 其他好文 > 详细

C - 这道题很难

时间:2015-08-19 16:47:58      阅读:92      评论:0      收藏:0      [点我收藏+]

标签:

Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u

Description

A certain prison contains a long hall of n cells, each right next to each other. Each cell has a prisoner in it, and each cell is locked. 
One night, the jailer gets bored and decides to play a game. For round 1 of the game, he takes a drink of whiskey, and then runs down the hall unlocking each cell. For round 2, he takes a drink of whiskey, and then runs down the hall locking every other cell (cells 2, 4, 6, …). For round 3, he takes a drink of whiskey, and then runs down the hall. He visits every third cell (cells 3, 6, 9, …). If the cell is locked, he unlocks it; if it is unlocked, he locks it. He repeats this for n rounds, takes a final drink, and passes out. 

Some number of prisoners, possibly zero, realizes that their cells are unlocked and the jailer is incapacitated. They immediately escape. 

Given the number of cells, determine how many prisoners escape jail. 
 

Input

The first line of input contains a single positive integer. This is the number of lines that follow. Each of the following lines contains a single integer between 5 and 100, inclusive, which is the number of cells n. 
 

Output

For each line, you must print out the number of prisoners that escape when the prison has n cells. 
 

Sample Input

2 5 100
 

Sample Output

2 10
 


#include<stdio.h>
int main()
{
	int n,m;
	scanf("%d",&n);
      while(n--)
   	 { 
		int i,x[1000];
		scanf("%d",&m);
		for(i=1;i<=m;i++)
		x[i]=0;
		int t=2;
		while(m>=t)
		{
			x[t]=1;
			t=t+2;
		}
		int w=3,q=3;
       int h=m-2;	
		while(h--)
		{
		    	while(m>=w)
		    {
			  if(x[w]==0)
			  x[w]=1;
			  else x[w]=0;
			   w=w+q;
		    }
		    q++;
		    w=q;
		}
		int sum=0;
		for(i=1;i<=m;i++)
		if(x[i]==0)
		sum++;
		printf("%d\n",sum);
	}
	return 0;
}

版权声明:本文为博主原创文章,未经博主允许不得转载。

C - 这道题很难

标签:

原文地址:http://blog.csdn.net/l15738519366/article/details/47782183

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!