码迷,mamicode.com
首页 > 其他好文 > 详细

ACM 概率&&动态规划

时间:2015-08-19 23:05:19      阅读:460      评论:0      收藏:0      [点我收藏+]

标签:

Description

As Harry Potter series is over, Harry has no job. Since he wants to make quick money, (he wants everything quick!) so he decided to rob banks. He wants to make a calculated risk, and grab as much money as possible. But his friends - Hermione and Ron have decided upon a tolerable probabilityP of getting caught. They feel that he is safe enough if the banks he robs together give a probability less than P.

Input

Input starts with an integer T (≤ 100), denoting the number of test cases.

Each case contains a real number P, the probability Harry needs to be below, and an integer N (0 < N ≤ 100), the number of banks he has plans for. Then follow N lines, where line j gives an integer Mj (0 < Mj ≤ 100) and a real number Pj . Bank j contains Mj millions, and the probability of getting caught from robbing it is Pj. A bank goes bankrupt if it is robbed, and you may assume that all probabilities are independent as the police have very low funds.

Output

For each case, print the case number and the maximum number of millions he can expect to get while the probability of getting caught is less than P.

Sample Input

3

0.04 3

1 0.02

2 0.03

3 0.05

0.06 3

2 0.03

2 0.03

3 0.05

0.10 3

1 0.03

2 0.02

3 0.05

Sample Output

Case 1: 2

Case 2: 4

Case 3: 6

解题思路
题目的大意是,Harry想要抢劫银行,每家银行多有一定的金额和被抓到的概率,知道Roy被抓的最大概率P,求Harry在没有被抓的情况下,抢劫最多的钱数。这是一个背包问题,我们只要做一点转化。把每个银行的储钱量之和当成背包容量,然后概率当成价值来求。这里是被抓的概率,我们把他转化成不被抓的概率,然后这里的和就可以转化成乘积了。然后利用01背包的模版就可以做出来了。
程序代码:
#include <iostream>
#include <cstring>
using namespace std;
int a[105];
double p[105];
double dp[10005];
double max(double x,double y)
{
    return x>y?x:y;
}
int main()
{
    int t,ff=1;
    cin>>t;
    while(t--)
    {
        memset(dp,0,sizeof(dp));
        dp[0]=1;//没有抢劫自然不会被抓
        int n,i,j,s=0;
        double p1;//被抓的概率
        cin>>p1>>n;
        p1=1-p1;//不被抓的概率
        for(i=1;i<=n;i++)
        {
            cin>>a[i]>>p[i];
            s+=a[i];
        }
        for(i=1;i<=n;i++)
        {
            for(j=s;j>=a[i];j--)
                dp[j]=max(dp[j],dp[j-a[i]]*(1-p[i]));
        }
        for(i=s;i>=0;i--)
        {
            if(dp[i]>=p1)
            {
                cout<<"Case "<<ff++<<": "<<i<<endl;
                break;
            }

        }
    }
    return 0;
}

 

ACM 概率&&动态规划

标签:

原文地址:http://www.cnblogs.com/xinxiangqing/p/4743492.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!