码迷,mamicode.com
首页 > 其他好文 > 详细

POJ 3624 (01背包)

时间:2015-08-20 01:07:01      阅读:189      评论:0      收藏:0      [点我收藏+]

标签:

Bessie has gone to the mall‘s jewelry store and spies a charm bracelet. Of course, she‘d like to fill it with the best charms possible from the N (1 ≤ N ≤ 3,402) available charms. Each charm i in the supplied list has a weight Wi (1 ≤ Wi ≤ 400), a ‘desirability‘ factor Di (1 ≤ Di ≤ 100), and can be used at most once. Bessie can only support a charm bracelet whose weight is no more than M (1 ≤ M ≤ 12,880).

Given that weight limit as a constraint and a list of the charms with their weights and desirability rating, deduce the maximum possible sum of ratings.

Input

* Line 1: Two space-separated integers: N and M
* Lines 2..N+1: Line i+1 describes charm i with two space-separated integers: Wi and Di

Output

* Line 1: A single integer that is the greatest sum of charm desirabilities that can be achieved given the weight constraints

Sample Input

4 6
1 4
2 6
3 12
2 7

Sample Output

23


这题我是先会的一维的,想明白了,再去看背包问题,结果发现用而二维的做会少,其实还是代码没写对

这题用二维做会MLE,它的意思就是要你用一维去做,不过我把二维一维的都写上来

一维
#include<queue>
#include<math.h>
#include<stdio.h>
#include<string.h>
#include<string>
#include<iostream>
#include<algorithm>
using namespace std;
#define N 1234567
#define M 12

int f[N];
int w[N];
int d[N];
int n,m;
int main()
{
    while(~scanf("%d %d",&n,&m))
    {
        for(int i=1;i<=n;i++)
            scanf("%d%d",&w[i],&d[i]);
        memset(f,0,sizeof(f));
        for(int j=1;j<=n;j++)
        {
            for(int i=m;i>=0;i--)
            {
                if(i>=w[j])
                    f[i]=max(f[i],f[i-w[j]]+d[j]);
            }

        }
        cout<<f[m]<<endl;
    }
    return 0;
}
/*
4 6
1 4
2 6
3 12
2 7
*/

二维

#include<queue>
#include<math.h>
#include<stdio.h>
#include<string.h>
#include<string>
#include<iostream>
#include<algorithm>
using namespace std;
#define N 12888
#define M 12

int f[N];
int g[4000][N];
int w[N];
int d[N];
int n,m;
int main()
{
    while(~scanf("%d %d",&n,&m))
    {
        for(int i=1;i<=n;i++)
            scanf("%d%d",&w[i],&d[i]);
        memset(g,0,sizeof(g));
        for(int i=1;i<=n;i++)
        {
            for(int v=m;v>=0;v--)
            {
                g[i][v]=g[i-1][v];//开始就是少了这一句老是不对
                if(v>=w[i])
                g[i][v]=max(g[i-1][v],g[i-1][v-w[i]]+d[i]);
            }
        }
        cout<<g[n][m]<<endl;
    }
    return 0;
}
/*
4 6
1 4
2 6
3 12
2 7
*/

 

POJ 3624 (01背包)

标签:

原文地址:http://www.cnblogs.com/wmxl/p/4743825.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!