码迷,mamicode.com
首页 > 其他好文 > 详细

Pku3673

时间:2014-07-12 19:19:02      阅读:164      评论:0      收藏:0      [点我收藏+]

标签:des   style   blog   color   os   2014   

<span style="color:#6600cc;">/*
B - Cow Multiplication
Time Limit:1000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u
Submit

Status

Practice

POJ 3673
Description
Bessie is tired of multiplying pairs of numbers the usual way, so she invented her own style of multiplication. In her style, A*B is equal to the sum of all possible pairwise products between the digits of A and B. For example, the product 123*45 is equal to 1*4 + 1*5 + 2*4 + 2*5 + 3*4 + 3*5 = 54. Given two integers A and B (1 ¡Ü A, B ¡Ü 1,000,000,000), determine A*B in Bessie's style of multiplication.

Input
* Line 1: Two space-separated integers: A and B.

Output
* Line 1: A single line that is the A*B in Bessie's style of multiplication.

Sample Input
123 45

Sample Output
54
By Grant Yuan
2014.7.11
*/
#include<iostream>
#include<stdio.h>
#include<string.h>
#include<stdlib.h>
using namespace std;
int main()
{
    int sum=0;
    char a[13],b[13];
    memset(a,0,12);
    memset(b,0,12);

    cin>>a>>b;
     int i,j;
    int o,q;
    o=strlen(a);
   q=strlen(b);

   int n1,n2;
   for(i=0;i<o;i++)
      for(j=0;j<q;j++)
      {
          n1=a[i]-48;
          n2=b[j]-48;
        sum+=n1*n2;
      }
      cout<<sum<<endl;
    return 0;

}

</span>


 

Pku3673,布布扣,bubuko.com

Pku3673

标签:des   style   blog   color   os   2014   

原文地址:http://blog.csdn.net/yuanchang_best/article/details/37671797

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!