码迷,mamicode.com
首页 > 其他好文 > 详细

HDOJ 1028 Ignatius and the Princess III(DP)

时间:2015-08-26 12:04:53      阅读:162      评论:0      收藏:0      [点我收藏+]

标签:dp

Problem Description
"Well, it seems the first problem is too easy. I will let you know how foolish you are later." feng5166 says.

"The second problem is, given an positive integer N, we define an equation like this:
  N=a[1]+a[2]+a[3]+...+a[m];
  a[i]>0,1<=m<=N;
My question is how many different equations you can find for a given N.
For example, assume N is 4, we can find:
  4 = 4;
  4 = 3 + 1;
  4 = 2 + 2;
  4 = 2 + 1 + 1;
  4 = 1 + 1 + 1 + 1;
so the result is 5 when N is 4. Note that "4 = 3 + 1" and "4 = 1 + 3" is the same in this problem. Now, you do it!"
 

Input
The input contains several test cases. Each test case contains a positive integer N(1<=N<=120) which is mentioned above. The input is terminated by the end of file.
 

Output
For each test case, you have to output a line contains an integer P which indicate the different equations you have found.
 

Sample Input
4 10 20
 

Sample Output
5 42 627


和上篇类似。

#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cstring>
#include<cmath>
#define LL __int64
#define inf 0x3f3f3f3f
using namespace std;
LL x,y;
LL dp[100010];
int main()
{
    LL n,m,k,i,j,l,c;
    while(~scanf("%lld",&n))
    {
        memset(dp,0,sizeof(dp));
        dp[0]=1;
        for(i=1; i<=n; i++)
        {
            for(j=i; j<=n; j++)
                dp[j]+=dp[j-i];
        }
        printf("%lld\n",dp[n]);
    }
    return 0;
}


版权声明:本文为博主原创文章,未经博主允许不得转载。

HDOJ 1028 Ignatius and the Princess III(DP)

标签:dp

原文地址:http://blog.csdn.net/grit_icpc/article/details/48000945

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!