码迷,mamicode.com
首页 > 其他好文 > 详细

Alignment

时间:2014-07-27 22:20:09      阅读:254      评论:0      收藏:0      [点我收藏+]

标签:des   style   blog   color   os   io   for   cti   

Description

In the army, a platoon is composed by n soldiers. During the morning inspection, the soldiers are aligned in a straight line in front of the captain. The captain is not satisfied with the way his soldiers are aligned; it is true that the soldiers are aligned in order by their code number: 1 , 2 , 3 , . . . , n , but they are not aligned by their height. The captain asks some soldiers to get out of the line, as the soldiers that remain in the line, without changing their places, but getting closer, to form a new line, where each soldier can see by looking lengthwise the line at least one of the line‘s extremity (left or right). A soldier see an extremity if there isn‘t any soldiers with a higher or equal height than his height between him and that extremity. 

Write a program that, knowing the height of each soldier, determines the minimum number of soldiers which have to get out of line. 

Input

On the first line of the input is written the number of the soldiers n. On the second line is written a series of n floating numbers with at most 5 digits precision and separated by a space character. The k-th number from this line represents the height of the soldier who has the code k (1 <= k <= n). 

There are some restrictions: 
• 2 <= n <= 1000 
• the height are floating numbers from the interval [0.5, 2.5] 

Output

The only line of output will contain the number of the soldiers who have to get out of the line.

Sample Input

8
1.86 1.86 1.30621 2 1.4 1 1.97 2.2

Sample Output

4

#include"iostream"
#include"algorithm"
using namespace std;
const int ms=1001;
int main()
{
    int n,i,j,k;
    double a[ms];
    int l[ms],r[ms];
    cin>>n;
    for(i=1;i<=n;i++)
        cin>>a[i];
    for(i=1;i<=n;i++)
    {
        l[i]=1;
        for(j=1;j<i;j++)
            if(a[j]<a[i])
                l[i]=max(l[i],l[j]+1);
    }
    for(i=n;i>0;i--)
    {
        r[i]=1;
        for(j=n;j>i;j--)
            if(a[i]>a[j])
                r[i]=max(r[i],r[j]+1);
    }
    int ans=0;
    for(i=1;i<=n;i++)
    {
        int tmp=0;
        for(j=i+1;j<=n;j++)
            if(a[i]>=a[j])
                tmp=max(tmp,r[j]);
        ans=max(ans,tmp+l[i]);
    }
    cout<<n-ans<<endl;
    return 0;
}

 

Alignment,布布扣,bubuko.com

Alignment

标签:des   style   blog   color   os   io   for   cti   

原文地址:http://www.cnblogs.com/767355675hutaishi/p/3871403.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!