码迷,mamicode.com
首页 > 其他好文 > 详细

zoj 3781 Paint the Grid Reloaded (比较隐含的最短路)

时间:2014-05-07 07:28:35      阅读:480      评论:0      收藏:0      [点我收藏+]

标签:style   blog   class   code   ext   color   

Paint the Grid Reloaded

Time Limit: 2 Seconds      Memory Limit: 65536 KB

Leo has a grid with N rows and M columns. All cells are painted with either black or white initially.

Two cells A and B are called connected if they share an edge and they are in the same color, or there exists a cell C connected to both A and B.

Leo wants to paint the grid with the same color. He can make it done in multiple steps. At each step Leo can choose a cell and flip the color (from black to white or from white to black) of all cells connected to it. Leo wants to know the minimum number of steps he needs to make all cells in the same color.

Input

There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:

The first line contains two integers N and M (1 <= N, M <= 40). Then N lines follow. Each line contains a string with N characters. Each character is either ‘X‘ (black) or ‘O‘ (white) indicates the initial color of the cells.

Output

For each test case, output the minimum steps needed to make all cells in the same color.

Sample Input

2
2 2
OX
OX
3 3
XOX
OXO
XOX

Sample Output

1
2

Hint

For the second sample, one optimal solution is:

Step 1. flip (2, 2)

XOX
OOO
XOX

Step 2. flip (1, 2)

XXX
XXX
XXX



题意:

给你一个染色的 N×M 的格子,你每次可以选择一个连通块,将其颜色取反。问最后将整个格子变为同色的最小步数。


思路:

其实就是一个最短路,将连通块缩点然后不同种的连通块之间连边,那么将整个格子变为同色的最小步数就等于一个点到地图上最远点的距离了。


代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <string>
#include <map>
#include <stack>
#include <vector>
#include <set>
#include <queue>
#pragma comment (linker,"/STACK:1024000000,1024000000")
#define maxn 45
#define MAXN 2700005
#define OO (1<<31)-1
#define mod 1000000009
#define INF 0x3f3f3f3f
#define pi acos(-1.0)
#define eps 1e-6
typedef long long ll;
using namespace std;

int n,m,ans,cnt,lev;
char mp[maxn][maxn];
int num[maxn][maxn];
int dx[]={0,0,-1,1};
int dy[]={-1,1,0,0};

bool vis[maxn][maxn],app[1605][1605];
int p[1700];
struct Node
{
    int v;
    int next;
}edge[MAXN];

void addedge(int u,int v)
{
    cnt++;
    edge[cnt].v=v;
    edge[cnt].next=p[u];
    p[u]=cnt;
}
bool isok(int x,int y)
{
    if(x<1||x>n||y<1||y>m) return false ;
    return true ;
}
void dfs(int x,int y)
{
    num[x][y]=lev;
    int nx,ny,i;
    for(i=0;i<4;i++)
    {
        nx=x+dx[i]; ny=y+dy[i];
        if(isok(nx,ny)&&!vis[nx][ny]&&mp[nx][ny]==mp[x][y])
        {
            vis[nx][ny]=1;
            dfs(nx,ny);
        }
    }
}
void presolve()
{
    memset(p,0,sizeof(p));
    int i,j,k,t,nx,ny;
    lev=0;
    memset(vis,0,sizeof(vis));
    for(i=1;i<=n;i++)
    {
        for(j=1;j<=m;j++)
        {
            if(!vis[i][j])
            {
                lev++;
                vis[i][j]=1;
                dfs(i,j);
            }
        }
    }
    cnt=0;
    memset(app,0,sizeof(app));
    for(i=1;i<=n;i++)
    {
        for(j=1;j<=m;j++)
        {
            for(k=0;k<4;k++)
            {
                nx=i+dx[k]; ny=j+dy[k];
                if(isok(nx,ny)&&num[nx][ny]!=num[i][j]&&!app[num[nx][ny]][num[i][j]])
                {
                    app[num[nx][ny]][num[i][j]]=1;
                    addedge(num[nx][ny],num[i][j]);
                }
            }
        }
    }
}
struct fuck
{
    int dis;
    int num;
}t,f;
bool VVV[2700];
queue<fuck> Q;
int bfs(int now)
{
    memset(VVV,0,sizeof(VVV));
    t.dis=0;
    t.num=now;
    VVV[now]=1;
    while(!Q.empty()) Q.pop();
    Q.push(t);
    int maxs=0;
    while(!Q.empty())
    {
        t=Q.front();Q.pop();
        if(t.dis>ans) return INF;
        for(int i=p[t.num];i!=0;i=edge[i].next)
        {
            int to=edge[i].v;
            if(!VVV[to])
            {
                VVV[to]=1;
                f.num=to;
                f.dis=t.dis+1;
                maxs=max(maxs,f.dis);
                Q.push(f);
            }
        }
    }
    return maxs;
}
int main()
{
    int i,j,t,u,v,w;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&n,&m);
        for(i=1;i<=n;i++)
        {
            scanf("%s",mp[i]+1);
        }
        presolve();
        ans=INF;
        for(int i=1;i<=lev;i++)
        {
            ans=min(ans,bfs(i));
        }
        printf("%d\n",ans);
    }
    return 0;
}


zoj 3781 Paint the Grid Reloaded (比较隐含的最短路),布布扣,bubuko.com

zoj 3781 Paint the Grid Reloaded (比较隐含的最短路)

标签:style   blog   class   code   ext   color   

原文地址:http://blog.csdn.net/tobewhatyouwanttobe/article/details/25082683

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!