码迷,mamicode.com
首页 > 其他好文 > 详细

POJ 3280 Cheapest Palindrome (DP)

时间:2014-07-29 13:22:46      阅读:212      评论:0      收藏:0      [点我收藏+]

标签:dp



Description

Keeping track of all the cows can be a tricky task so Farmer John has installed a system to automate it. He has installed on each cow an electronic ID tag that the system will read as the cows pass by a scanner. Each ID tag‘s contents are currently a single string with length M (1 ≤ M ≤ 2,000) characters drawn from an alphabet of N (1 ≤ N ≤ 26) different symbols (namely, the lower-case roman alphabet).

Cows, being the mischievous creatures they are, sometimes try to spoof the system by walking backwards. While a cow whose ID is "abcba" would read the same no matter which direction the she walks, a cow with the ID "abcb" can potentially register as two different IDs ("abcb" and "bcba").

FJ would like to change the cows‘s ID tags so they read the same no matter which direction the cow walks by. For example, "abcb" can be changed by adding "a" at the end to form "abcba" so that the ID is palindromic (reads the same forwards and backwards). Some other ways to change the ID to be palindromic are include adding the three letters "bcb" to the begining to yield the ID "bcbabcb" or removing the letter "a" to yield the ID "bcb". One can add or remove characters at any location in the string yielding a string longer or shorter than the original string.

Unfortunately as the ID tags are electronic, each character insertion or deletion has a cost (0 ≤ cost ≤ 10,000) which varies depending on exactly which character value to be added or deleted. Given the content of a cow‘s ID tag and the cost of inserting or deleting each of the alphabet‘s characters, find the minimum cost to change the ID tag so it satisfies FJ‘s requirements. An empty ID tag is considered to satisfy the requirements of reading the same forward and backward. Only letters with associated costs can be added to a string.

Input

Line 1: Two space-separated integers: N and M
Line 2: This line contains exactly M characters which constitute the initial ID string
Lines 3..N+2: Each line contains three space-separated entities: a character of the input alphabet and two integers which are respectively the cost of adding and deleting that character.

Output

Line 1: A single line with a single integer that is the minimum cost to change the given name tag.

Sample Input

3 4
abcb
a 1000 1100
b 350 700
c 200 800

Sample Output

900

题意:一串字母序列,经过增加或删减某个字符使得序列成为回文,增加和删减都有花费,问花费最少多少。
设dp[i][j]为从i到j的花费,
dp[i][j] = min ( dp[i+1][j]+cost[i] , dp[i][j-1]+cost[j] );  ( a[i] != a[j] )
dp[i][j] = dp[i+1][j-1] ( a[i] == a[j] )
cost[]里存的就是每个字符删减或者增加的较小的值,因为删掉a[i]和在j后面增加一个a[i]效果是一样的,只需比较两者的花费谁更小

#include <stdio.h>
#include <string.h>
#include <algorithm>
#include <math.h>
using namespace std;
typedef long long LL;
const int MAX=0x3f3f3f3f;
int n,m,cost[30],dp[2007][2005];
char s[2005],cc[3];
int main()
{
    scanf("%d%d%s",&n,&m,s);
    for(int i=0;i<n;i++) {
        int xx,yy;
        scanf("%s %d %d",cc,&xx,&yy);
        cost[ cc[0]-'a' ] = min(xx,yy);
    }
    for(int j=1;j<m;j++)
        for(int i=j-1;i>=0;i--)
             if( s[i] == s[j] ) dp[i][j] = dp[i+1][j-1];
             else dp[i][j] = min( dp[i+1][j]+cost[ s[i]-'a' ] ,dp[i][j-1]+cost[ s[j]-'a' ] );
    printf("%d\n",dp[0][m-1]);
    return 0;
}


POJ 3280 Cheapest Palindrome (DP),布布扣,bubuko.com

POJ 3280 Cheapest Palindrome (DP)

标签:dp

原文地址:http://blog.csdn.net/u013923947/article/details/38239623

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!