码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 3635 Dragon Balls 带权并查集

时间:2014-05-07 02:45:21      阅读:345      评论:0      收藏:0      [点我收藏+]

标签:des   style   blog   class   code   java   

Dragon Balls

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2577    Accepted Submission(s): 993


Problem Description
Five hundred years later, the number of dragon balls will increase unexpectedly, so it‘s too difficult for Monkey King(WuKong) to gather all of the dragon balls together. 
bubuko.com,布布扣

His country has N cities and there are exactly N dragon balls in the world. At first, for the ith dragon ball, the sacred dragon will puts it in the ith city. Through long years, some cities‘ dragon ball(s) would be transported to other cities. To save physical strength WuKong plans to take Flying Nimbus Cloud, a magical flying cloud to gather dragon balls. 
Every time WuKong will collect the information of one dragon ball, he will ask you the information of that ball. You must tell him which city the ball is located and how many dragon balls are there in that city, you also need to tell him how many times the ball has been transported so far.
 

Input
The first line of the input is a single positive integer T(0 < T <= 100). 
For each case, the first line contains two integers: N and Q (2 < N <= 10000 , 2 < Q <= 10000).
Each of the following Q lines contains either a fact or a question as the follow format:
  T A B : All the dragon balls which are in the same city with A have been transported to the city the Bth ball in. You can assume that the two cities are different.
  Q A : WuKong want to know X (the id of the city Ath ball is in), Y (the count of balls in Xth city) and Z (the tranporting times of the Ath ball). (1 <= A, B <= N)
 

Output
For each test case, output the test case number formated as sample output. Then for each query, output a line with three integers X Y Z saparated by a blank space.
 

Sample Input
2 3 3 T 1 2 T 3 2 Q 2 3 4 T 1 2 Q 1 T 1 3 Q 1
 

Sample Output
Case 1: 2 3 0 Case 2: 2 2 1 3 3 2
 

Author
possessor WC
 

Source

有n个城市,每个城市都有一个龙珠,有两种操作:
T A B:将A龙珠所在的城市的所有龙珠都转移到B龙珠所在的城市。
Q A:找出这个城市X(A龙珠所在的城市),Y(在第X城市所有龙珠的数量),Z(A龙珠转移的次数)。
用并查集做,求X也就是求A根,求Y就是求树上所有的元素个数,求Z的时候,只需要让根节点的移动次数+1,然后在find函数里面路径压缩,进行更新。
//687MS	324K
#include<stdio.h>
#include<string.h>
#define M 10007
struct node
{
    int pre,son,tan;
} p[M];
int find(int x)
{
    if(p[x].pre==x)return x;
    else
    {
        int xx=p[x].pre;
        p[x].pre=find(p[x].pre);
        p[x].tan+=p[xx].tan;
    }
    return p[x].pre;
}
void unio(int a,int b)
{
    int x=find(a);
    int y=find(b);
    if(x==y)return;
    p[x].pre=y;
    p[x].tan++;
    p[y].son+=p[x].son;
    p[x].son=0;
}
int main()
{
    int t,cas=1;
    scanf("%d",&t);
    while(t--)
    {
        int n,q;
        scanf("%d%d",&n,&q);
        for(int i=1; i<=n; i++)
        {
            p[i].pre=i;
            p[i].son=1;
            p[i].tan=0;
        }
        printf("Case %d:\n",cas++);
        int a,b,c;
        char s[2];
        for(int i=0; i<q; i++)
        {
            scanf("%s",s);
            if(s[0]==‘T‘)
            {
                scanf("%d%d",&a,&b);
                unio(a,b);
            }
            else
            {
                scanf("%d",&c);
                int ans=find(c);
                printf("%d %d %d\n",p[ans].pre,p[ans].son,p[c].tan);
            }
        }
    }
    return 0;
}


HDU 3635 Dragon Balls 带权并查集,布布扣,bubuko.com

HDU 3635 Dragon Balls 带权并查集

标签:des   style   blog   class   code   java   

原文地址:http://blog.csdn.net/crescent__moon/article/details/25129985

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!