码迷,mamicode.com
首页 > 其他好文 > 详细

HDU1540 Tunnel Warfare

时间:2014-05-06 22:05:11      阅读:376      评论:0      收藏:0      [点我收藏+]

标签:des   style   blog   class   code   ext   

Problem Description
During the War of Resistance Against Japan, tunnel warfare was carried out extensively in the vast areas of north China Plain. Generally speaking, villages connected by tunnels lay in a line. Except the two at the ends, every village was directly connected with two neighboring ones.

Frequently the invaders launched attack on some of the villages and destroyed the parts of tunnels in them. The Eighth Route Army commanders requested the latest connection state of the tunnels and villages. If some villages are severely isolated, restoration of connection must be done immediately!
 

Input
The first line of the input contains two positive integers n and m (n, m ≤ 50,000) indicating the number of villages and events. Each of the next m lines describes an event.

There are three different events described in different format shown below:

D x: The x-th village was destroyed.

Q x: The Army commands requested the number of villages that x-th village was directly or indirectly connected with including itself.

R: The village destroyed last was rebuilt.
 

Output
Output the answer to each of the Army commanders’ request in order on a separate line.
 

Sample Input
7 9 D 3 D 6 D 5 Q 4 Q 5 R Q 4 R Q 4
 

Sample Output
1 0 2 4
可用set来保存 炸毁的点 查询的时候二分 到它的左右两个数(当查询的数在set中直接输出0) 相减即为所得!
一开始RE了很久。。。得到一个教训就是 用upper_bound 和 lower_bound的时候最好给set加个边界。。不然迭代器自减的话会发生很多乱七八糟的情况
#include <iostream>
#include <cstdio>
#include <cstring>
#include <vector>
#include <string>
#include <algorithm>
#include <queue>
#include <stack>
#include <set>
using namespace std;
int n,m;
set<int> sv;
stack<int> dv;
int main(){
    
    while(~scanf("%d%d",&n,&m)){
        while(!dv.empty()) dv.pop();
        sv.clear();
        sv.insert(0);//给其加上边界
        sv.insert(n+1);
        while(m--){
            getchar();
            set<int>::iterator itlow,itup;
            char op;
            int d;
            scanf("%c",&op);
            if(op==‘D‘){
                scanf("%d",&d);
                dv.push(d);
                sv.insert(d);
            }else if(op == ‘R‘){
                if(!dv.empty()){
                    int td = dv.top();
                    dv.pop();
                    if(sv.count(td)!=0){
                        sv.erase(td);
                    }
                }
            }else{
                scanf("%d",&d);
                if(sv.count(d)!=0){
                    printf("0\n");
                }else{
                    int ans = 0;
                    itlow = sv.lower_bound(d);
                    itup = sv.upper_bound(d);
                    itlow--;
                    printf("%d\n",*itup-*itlow-1);
                }
            }

        }
    }
    return 0;
}


HDU1540 Tunnel Warfare,布布扣,bubuko.com

HDU1540 Tunnel Warfare

标签:des   style   blog   class   code   ext   

原文地址:http://blog.csdn.net/mowayao/article/details/25117941

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!