码迷,mamicode.com
首页 > 其他好文 > 详细

hdu oj 3371 Connect the Cities (最小生成树)

时间:2014-08-10 18:42:10      阅读:236      评论:0      收藏:0      [点我收藏+]

标签:acm   算法   最小生成树   

Connect the Cities

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 9985    Accepted Submission(s): 2843


Problem Description
In 2100, since the sea level rise, most of the cities disappear. Though some survived cities are still connected with others, but most of them become disconnected. The government wants to build some roads to connect all of these cities again, but they don’t want to take too much money.  
 

Input
The first line contains the number of test cases.
Each test case starts with three integers: n, m and k. n (3 <= n <=500) stands for the number of survived cities, m (0 <= m <= 25000) stands for the number of roads you can choose to connect the cities and k (0 <= k <= 100) stands for the number of still connected cities.
To make it easy, the cities are signed from 1 to n.
Then follow m lines, each contains three integers p, q and c (0 <= c <= 1000), means it takes c to connect p and q.
Then follow k lines, each line starts with an integer t (2 <= t <= n) stands for the number of this connected cities. Then t integers follow stands for the id of these cities.
 

Output
For each case, output the least money you need to take, if it’s impossible, just output -1.
 

Sample Input
1 6 4 3 1 4 2 2 6 1 2 3 5 3 4 33 2 1 2 2 1 3 3 4 5 6
 

Sample Output
1
 

Author
dandelion
 

Source
 
这道题要把题意多读几遍,理清题意,然后直接用prim就直接水过,大概题意是已知了一些连接的边,这里要处理的就是已经连接的边,我这里把已经连接的边处理为权值为0,然后其他边就和按照prim算法加入最小生成树,如果最小生成树的权值大于设定的最大值了,说明有些路不通,输出-1,是通路就直接输出最小生成树的权值,这里最关键的就是对已经连接的边进行处理;还有就是要注意没有联通的情况,其他的和一般的prim一样。
下面是代码;
#include <cstdio>
#include <cstring>
using namespace std;
const int maxn=505;
const int Max=0x3f3f3f3f;
int map[maxn][maxn],low[maxn],visit[maxn];
int n,m,k;
void prim()
{
    int i,j,pos,min,mst=0;
    memset(visit,0,sizeof(visit));
    pos=1;
    visit[1]=1;
    for(i=1;i<=n;i++)
        low[i]=map[pos][i];
    for(i=1;i<n;i++)
    {
        min=Max;
        for(j=1;j<=n;j++)/更新min的值
        {
            if(!visit[j] && min>low[j])
            {
                min=low[j];
                pos=j;
            }
        }
        mst+=min;
        if(mst>=Max) break;//说明这个图不连通
        visit[pos]=j;
        for(j=1;j<=n;j++)
        {
            if(!visit[j] && low[j]>map[pos][j])//更新low数组
                low[j]=map[pos][j];
        }
    }
    if(mst>=Max)
        printf("-1\n");
    else
        printf("%d\n",mst);
}
int main()
{
    int t,i,j,x;
    int p,q,c;
    int a[101];
    scanf("%d",&t);
    while(t--)
    {
        memset(map,Max,sizeof(map));
        scanf("%d%d%d",&n,&m,&k);
        for(i=0;i<m;i++)
        {
            scanf("%d%d%d",&p,&q,&c);
            if(map[p][q]>c)//这里也要注意一下,题目没说有重边,但是数据里面有,没加这个就wa
            map[p][q]=map[q][p]=c;
        }
        while(k--)//处理已连接的边,把权值赋0;
		{
			scanf("%d",&x);
			for(i=1;i<=x;i++)
				scanf("%d",&a[i]);
			for(i=1;i<=x;i++)
				for(j=1;j<=x;j++)
					map[a[i]][a[j]]=0;
		}
       prim();
    }
    return 0;
}


hdu oj 3371 Connect the Cities (最小生成树),布布扣,bubuko.com

hdu oj 3371 Connect the Cities (最小生成树)

标签:acm   算法   最小生成树   

原文地址:http://blog.csdn.net/whjkm/article/details/38471187

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!