码迷,mamicode.com
首页 > 其他好文 > 详细

STL万岁。。 CODEVS 1230。

时间:2016-11-10 01:32:28      阅读:123      评论:0      收藏:0      [点我收藏+]

标签:com   lap   style   display   output   输出   pre   return   main   

题目描述 Description

给出n个正整数,然后有m个询问,每个询问一个整数,询问该整数是否在n个正整数中出现过。

输入描述 Input Description

第一行两个整数 n 和m。

第二行n个正整数(1<=n<= 100000)

第三行m个整数(1<=m<=100000)

输出描述 Output Description

一共m行,若出现则输出YES,否则输出NO

样例输入 Sample Input

4 2

2 1 3 4

1 9

样例输出 Sample Output

YES

NO

数据范围及提示 Data Size & Hint

所有数据都不超过10^8

分类标签 Tags 

STL是个神奇的东西。

技术分享
#include<map>
#include<iostream>
using namespace std;
int s[100001];
map<int,bool>g;
int main()
{
    int n,m,ss;
    cin>>n>>m;
    for(int i=1;i<=n;++i)
    {
    cin>>s[i];
    g[s[i]]=1;
    }
    for(int i=1;i<=m;++i)
    {
        cin>>ss;
        if(g[ss]==1)
        cout<<"YES"<<endl;
        else cout<<"NO"<<endl;
    }
    return 0;
}
View Code

 

STL万岁。。 CODEVS 1230。

标签:com   lap   style   display   output   输出   pre   return   main   

原文地址:http://www.cnblogs.com/ruojisun/p/6048935.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!