码迷,mamicode.com
首页 > 其他好文 > 详细

HDU-1716

时间:2014-08-14 23:52:16      阅读:283      评论:0      收藏:0      [点我收藏+]

标签:des   blog   io   数据   ar   2014   cti   div   

/********************************************************************
* @file     Main_practise.cpp
* @date     2014-8-14
* @author   Tiger
* @brief    排列2
* @details  Problem Description
			Ray又对数字的列产生了兴趣:
			现有四张卡片,用这四张卡片能排列出很多不同的4位数,要
			求按从小到大的顺序输出这些4位数。

			Input
			每组数据占一行,代表四张卡片上的数字(0<=数字<=9),如
			果四张卡片都是0,则输入结束。

			Output
			对每组卡片按从小到大的顺序输出所有能由这四张卡片组成的
			4位数,千位数字相同的在同一行,同一行中每个四位数间用空
			格分隔。每组输出数据间空一行,最后一组数据后面没有空行。

			Sample Input

			1 2 3 4
			1 1 2 3
			0 1 2 3
			0 0 0 0

			Sample Output

			1234 1243 1324 1342 1423 1432
			2134 2143 2314 2341 2413 2431
			3124 3142 3214 3241 3412 3421
			4123 4132 4213 4231 4312 4321
			
			1123 1132 1213 1231 1312 1321
			2113 2131 2311
			3112 3121 3211
			
			1023 1032 1203 1230 1302 1320
			2013 2031 2103 2130 2301 2310
			3012 3021 3102 3120 3201 3210
********************************************************************/
#include <string>
#include <algorithm>
#include <cstdio>

bool GetInput(std::string& str);

int main(int argc, const char* argv[])
{
	std::string str;
	bool bWholeFirst = true;
	while (GetInput(str) && str != "0000")
	{
		if (bWholeFirst)
		{
			bWholeFirst = false;
		}
		else
		{
			printf("\n");
		}

		bool bSingleFirst = true;
		char cFirst = str.at(str.find_first_not_of(‘0‘));
		do 
		{
			if (str.at(0) != ‘0‘)
			{
				if (bSingleFirst)
				{
					printf("%s", str.c_str());
					bSingleFirst = false;
				}
				else
				{
					if (str.at(0) != cFirst)
					{
						cFirst = str.at(0);
						printf("\n");
					}
					else
					{
						printf(" ");
					}
					printf("%s", str.c_str());
				}
			}
		} while (next_permutation(str.begin(), str.end()));
		printf("\n");
	}

	return 0;
}

bool GetInput(std::string& str)
{
	str.clear();
	int a, b, c, d;
	if (scanf("%d%d%d%d%*c", &a, &b, &c, &d) == EOF)
	{
		return false;
	}
	else
	{
		str.push_back(a+‘0‘);
		str.push_back(b+‘0‘);
		str.push_back(c+‘0‘);
		str.push_back(d+‘0‘);
		sort(str.begin(), str.end());
		return true;
	}
}

 

HDU-1716,布布扣,bubuko.com

HDU-1716

标签:des   blog   io   数据   ar   2014   cti   div   

原文地址:http://www.cnblogs.com/roronoa-zoro-zrh/p/3913570.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!