码迷,mamicode.com
首页 > 其他好文 > 详细

poj 1961 Period

时间:2017-03-01 20:39:08      阅读:175      评论:0      收藏:0      [点我收藏+]

标签:efi   input   ble   font   plm   single   field   sea   tput   

Period
Time Limit: 3000MS   Memory Limit: 30000K
     

Description

For each prefix of a given string S with N characters (each character has an ASCII code between 97 and 126, inclusive), we want to know whether the prefix is a periodic string. That is, for each i (2 <= i <= N) we want to know the largest K > 1 (if there is one) such that the prefix of S with length i can be written as AK ,that is A concatenated K times, for some string A. Of course, we also want to know the period K.

Input

The input consists of several test cases. Each test case consists of two lines. The first one contains N (2 <= N <= 1 000 000) – the size of the string S.The second line contains the string S. The input file ends with a line, having the 
number zero on it.

Output

For each test case, output "Test case #" and the consecutive test case number on a single line; then, for each prefix with length i that has a period K > 1, output the prefix size i and the period K separated by a single space; the prefix sizes must be in increasing order. Print a blank line after each test case.

Sample Input

3
aaa
12
aabaabaabaab
0

Sample Output

Test case #1
2 2
3 3

Test case #2
2 2
6 2
9 3
12 4

Source

题目大意:对于字符串的每个位置i(i>1),若到i,i之前有循环节,输出i及其长度
#include<cstdio>
#include<cstring>
#include<iostream>
using namespace std;
int n,t;
char s[1000001];
int f[1000010];
void getnext()
{
    for(int i=1;i<n;i++)
    {
        int j=f[i];
        while(j&&s[i]!=s[j]) j=f[j];
        f[i+1]= s[i]==s[j] ? j+1:0;
        if(i>=1&&f[i+1])
        {
            int a=i+1-f[i+1];
            if((i+1)%a==0) printf("%d %d\n",i+1,(i+1)/a);
        }
    }
}
int main()
{
    while(scanf("%d",&n)!=EOF)
    {
            t++;
            if(!n) return 0;
            scanf("%s",s);
            memset(f,0,sizeof(f));
            printf("Test case #%d\n",t);
            getnext();
            printf("\n");
    }    
}

 

poj 1961 Period

标签:efi   input   ble   font   plm   single   field   sea   tput   

原文地址:http://www.cnblogs.com/TheRoadToTheGold/p/6485880.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!