码迷,mamicode.com
首页 > 其他好文 > 详细

【BZOJ3011】[Usaco2012 Dec]Running Away From the Barn 可并堆

时间:2017-03-10 20:34:44      阅读:189      评论:0      收藏:0      [点我收藏+]

标签:could   turn   can   ota   val   out   scan   ros   first   

【BZOJ3011】[Usaco2012 Dec]Running Away From the Barn

Description

It‘s milking time at Farmer John‘s farm, but the cows have all run away! Farmer John needs to round them all up, and needs your help in the search. FJ‘s farm is a series of N (1 <= N <= 200,000) pastures numbered 1...N connected by N - 1 bidirectional paths. The barn is located at pasture 1, and it is possible to reach any pasture from the barn. FJ‘s cows were in their pastures this morning, but who knows where they ran to by now. FJ does know that the cows only run away from the barn, and they are too lazy to run a distance of more than L. For every pasture, FJ wants to know how many different pastures cows starting in that pasture could have ended up in. Note: 64-bit integers (int64 in Pascal, long long in C/C++ and long in Java) are needed to store the distance values. 

给出以1号点为根的一棵有根树,问每个点的子树中与它距离小于l的点有多少个。

Input

 * Line 1: 2 integers, N and L (1 <= N <= 200,000, 1 <= L <= 10^18)

* Lines 2..N: The ith line contains two integers p_i and l_i. p_i (1 <= p_i < i) is the first pasture on the shortest path between pasture i and the barn, and l_i (1 <= l_i <= 10^12) is the length of that path.

Output

* Lines 1..N: One number per line, the number on line i is the number pastures that can be reached from pasture i by taking roads that lead strictly farther away from the barn (pasture 1) whose total length does not exceed L.

Sample Input

4 5
1 4
2 3
1 5

Sample Output

3
2
1
1
OUTPUT DETAILS: Cows from pasture 1 can hide at pastures 1, 2, and 4. Cows from pasture 2 can hide at pastures 2 and 3. Pasture 3 and 4 are as far from the barn as possible, and the cows can hide there.

题解:维护一个大根堆,堆中元素的权值就是i到根节点的距离,然后不断弹出堆顶直到堆顶元素的权值小于l就行了

#include <cstdio>
#include <cstring>
#include <iostream>
using namespace std;
const int maxn=200010;
typedef long long ll;
int n,rt[maxn],fa[maxn],siz[maxn],ch[maxn][2],nvl[maxn],head[maxn],next[maxn];
ll dep[maxn],val[maxn],l;
int merge(int x,int y)
{
	if(!x)	return y;
	if(!y)	return x;
	if(dep[x]<dep[y])	swap(x,y);
	ch[x][1]=merge(ch[x][1],y);
	if(nvl[ch[x][0]]<nvl[ch[x][1]])	swap(ch[x][0],ch[x][1]);
	nvl[x]=nvl[ch[x][1]]+1;
	return x;
}
void dfs(int x)
{
	siz[x]=1;
	for(int i=head[x];i;i=next[i])
	{
		dep[i]=dep[x]+val[i];
		dfs(i);
		siz[x]+=siz[i];
		rt[x]=merge(rt[x],rt[i]);
		while(dep[rt[x]]>l+dep[x])
		{
			siz[x]--;
			rt[x]=merge(ch[rt[x]][0],ch[rt[x]][1]);
		}
	}
}
int main()
{
	scanf("%d%lld",&n,&l);
	nvl[0]=-1;
	int i;
	rt[1]=1;
	for(i=2;i<=n;i++)
	{
		scanf("%d%lld",&fa[i],&val[i]);
		next[i]=head[fa[i]],head[fa[i]]=i;
		rt[i]=i;
	}
	dfs(1);
	for(i=1;i<=n;i++)	printf("%d\n",siz[i]);
	return 0;
}
 

【BZOJ3011】[Usaco2012 Dec]Running Away From the Barn 可并堆

标签:could   turn   can   ota   val   out   scan   ros   first   

原文地址:http://www.cnblogs.com/CQzhangyu/p/6532877.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!