码迷,mamicode.com
首页 > 其他好文 > 详细

[USACO08NOV]奶牛混合起来Mixed Up Cows

时间:2017-04-29 23:24:58      阅读:207      评论:0      收藏:0      [点我收藏+]

标签:sub   seq   names   color   eve   mat   namespace   led   logs   

题目描述

Each of Farmer John‘s N (4 <= N <= 16) cows has a unique serial number S_i (1 <= S_i <= 25,000). The cows are so proud of it that each one now wears her number in a gangsta manner engraved in large letters on a gold plate hung around her ample bovine neck.

Gangsta cows are rebellious and line up to be milked in an order called ‘Mixed Up‘. A cow order is ‘Mixed Up‘ if the sequence of serial numbers formed by their milking line is such that the serial numbers of every pair of consecutive cows in line differs by more than K (1 <= K <= 3400). For example, if N = 6 and K = 1 then 1, 3, 5, 2, 6, 4 is a ‘Mixed Up‘ lineup but 1, 3, 6, 5, 2, 4 is not (since the consecutive numbers 5 and 6 differ by 1).

How many different ways can N cows be Mixed Up?

For your first 10 submissions, you will be provided with the results of running your program on a part of the actual test data.

POINTS: 200

约翰家有N头奶牛,第i头奶牛的编号是Si,每头奶牛的编号都是唯一的。这些奶牛最近 在闹脾气,为表达不满的情绪,她们在挤奶的时候一定要排成混乱的队伍。在一只混乱的队 伍中,相邻奶牛的编号之差均超过K。比如当K = 1时,1, 3, 5, 2, 6, 4就是一支混乱的队伍, 而1, 3, 6, 5, 2, 4不是,因为6和5只差1。请数一数,有多少种队形是混乱的呢?

输入输出格式

输入格式:
  • Line 1: Two space-separated integers: N and K

  • Lines 2..N+1: Line i+1 contains a single integer that is the serial number of cow i: S_i
输出格式:
  • Line 1: A single integer that is the number of ways that N cows can be ‘Mixed Up‘. The answer is guaranteed to fit in a 64 bit integer.

输入输出样例

输入样例#1:
4 1 
3 
4 
2 
1 
输出样例#1:
2 

说明

The 2 possible Mixed Up arrangements are:

3 1 4 2

2 4 1 3

状压DP经典题,cnt为总的情况数,先定义一个t数组可以提高每一次计算1<<(j-1)的效率。

f[i][j]表示第i种状态下以j结尾的队伍有多少种混乱的队列。

然后i循环每一种状态,j循环每一个点。DP即可。。。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<cstdlib>
#include<algorithm>
using namespace std;
long long n,m;
long long f[1<<16][17],s[17],t[17];
int main()
{
    long long i,j,k,ans=0;
    cin>>n>>m;
    for(i=1;i<=n;i++)cin>>s[i];
    for(i=1;i<=n;i++)t[i]=1<<i-1;
    int cnt=(1<<n)-1;
    for(i=1;i<=n;i++)f[t[i]][i]=1;
    for(i=0;i<cnt;i++)
        for(j=1;j<=n;j++)
            if(!(t[j]&i))
                for(k=1;k<=n;k++)
                    if(t[k]&i&&abs(s[j]-s[k])>m)
                    {
                        f[i|t[j]][j]+=f[i][k];
                    }
    for(i=1;i<=n;i++)
    ans+=f[cnt][i];
    cout<<ans;
    return 0;
}

 

[USACO08NOV]奶牛混合起来Mixed Up Cows

标签:sub   seq   names   color   eve   mat   namespace   led   logs   

原文地址:http://www.cnblogs.com/huangdalaofighting/p/6786493.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!