码迷,mamicode.com
首页 > Web开发 > 详细

POJ 1258:Agri-Net(最小生成树&&prim)

时间:2017-04-30 14:11:56      阅读:239      评论:0      收藏:0      [点我收藏+]

标签:miss   self   another   math   logic   har   family   oid   cti   


Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 38918   Accepted: 15751

Description

Farmer John has been elected mayor of his town! One of his campaign promises was to bring internet connectivity to all farms in the area. He needs your help, of course. 
Farmer John ordered a high speed connection for his farm and is going to share his connectivity with the other farmers. To minimize cost, he wants to lay the minimum amount of optical fiber to connect his farm to all the other farms. 
Given a list of how much fiber it takes to connect each pair of farms, you must find the minimum amount of fiber needed to connect them all together. Each farm must connect to some other farm such that a packet can flow from any one farm to any other farm. 
The distance between any two farms will not exceed 100,000. 

Input

The input includes several cases. For each case, the first line contains the number of farms, N (3 <= N <= 100). The following lines contain the N x N conectivity matrix, where each element shows the distance from on farm to another. Logically, they are N lines of N space-separated integers. Physically, they are limited in length to 80 characters, so some lines continue onto others. Of course, the diagonal will be 0, since the distance from farm i to itself is not interesting for this problem.

Output

For each case, output a single integer length that is the sum of the minimum length of fiber required to connect the entire set of farms.

Sample Input

4
0 4 9 21
4 0 8 17
9 8 0 16
21 17 16 0

Sample Output

28

简单的最小生成树问题。

。题意要你求得最短的距离。

。1A水过



#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
#include<vector>
#include<queue>
#include<cmath>

using namespace std;
const int INF = 0x3f3f3f3f;
int map[105][105];//地图
int lowlen[105];//最短距离
int vist[105];//prim中用于看节点是否进树
int ans;
int n;

void init()
{
    for(int i=1; i<=n; i++)
        for(int j=1; j<=n; j++)
            scanf("%d", &map[i][j]);
    memset(vist, 0, sizeof(vist));
    memset(lowlen, 0, sizeof(lowlen));
}

void prim()//prim算法
{
    int temp;
    ans = 0;
    for(int i=1; i<=n; i++)
        lowlen[i] = map[1][i];
    vist[1] = -1;
    for(int i=2; i<=n; i++)
    {
        temp = INF;
        int k =0;
        for(int j=1; j<=n; j++)
        {
            if( vist[j]!=-1 && temp>lowlen[j] )
            {
                temp = lowlen[j];
                k = j;
            }
        }
        vist[k] = -1;
        ans += temp;
        for(int j=1; j<=n; j++)
        {
            if(vist[j]!=-1 && lowlen[j]>map[k][j])
            {
                lowlen[j] = map[k][j];
            }
        }
    }
    printf("%d\n", ans);
}

int main()
{
    while(scanf("%d", &n)==1)
    {
        init();
        prim();
    }

    return 0;
}







POJ 1258:Agri-Net(最小生成树&amp;&amp;prim)

标签:miss   self   another   math   logic   har   family   oid   cti   

原文地址:http://www.cnblogs.com/llguanli/p/6789158.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!