码迷,mamicode.com
首页 > 其他好文 > 详细

poj3461 Oulipo

时间:2017-05-23 19:39:11      阅读:182      评论:0      收藏:0      [点我收藏+]

标签:stream   time   one   single   over   splay   find   man   class   

Oulipo
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 40443   Accepted: 16266

Description

The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter ‘e‘. He was a member of the Oulipo group. A quote from the book:

Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination, l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais…

Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program that counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive‘T‘s is not unusual. And they never use spaces.

So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {‘A‘‘B‘‘C‘, …, ‘Z‘} and two finite strings over that alphabet, a word W and a text T, count the number of occurrences of W in T. All the consecutive characters of W must exactly match consecutive characters of T. Occurrences may overlap.

Input

The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:

  • One line with the word W, a string over {‘A‘‘B‘‘C‘, …, ‘Z‘}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W).
  • One line with the text T, a string over {‘A‘‘B‘‘C‘, …, ‘Z‘}, with |W| ≤ |T| ≤ 1,000,000.

Output

For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T.

Sample Input

3
BAPC
BAPC
AZA
AZAZAZA
VERDI
AVERDXIVYERDIAN

Sample Output

1
3
0

Source

kmp算法
#include<cstdio>
#include<cstring>
#include<algorithm>
#include <iostream>
#include <string>
using namespace std;
int next[ 100010];
char a[1000100],b[100010];
int lena,lenb;
void get_next()
{
    memset(next,0,sizeof(next));
    for(int i=1;i<lenb;i++)
    {
        int j=next[i];
        while(j&&b[i]!=b[j])
            j=next[j];
        next[i+1]=(b[i]==b[j])?j+1:0;
    }
}

int kmp()
{
    int ans=0;
    int j=0;
    for(int i=0;i<lena;i++)
    {
        while(j&&a[i]!=b[j])
            j=next[j];
        if(a[i]==b[j])
            j++;
        if(j==lenb)
            ans++;
    }
    return ans;
}

int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%s%s",b,a);
        lena=strlen(a);
        lenb=strlen(b);
        get_next();
        int ans=kmp();
        printf("%d\n",ans);
    }
    return 0;
}

 

 

poj3461 Oulipo

标签:stream   time   one   single   over   splay   find   man   class   

原文地址:http://www.cnblogs.com/asuml/p/6895556.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!