码迷,mamicode.com
首页 > 其他好文 > 详细

杭电1020Encoding

时间:2017-05-24 12:51:44      阅读:210      评论:0      收藏:0      [点我收藏+]

标签:put   accept   cas   技术   class   break   lin   following   gre   

Encoding

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 33249    Accepted Submission(s): 14785


Problem Description
Given a string containing only ‘A‘ - ‘Z‘, we could encode it using the following method: 

1. Each sub-string containing k same characters should be encoded to "kX" where "X" is the only character in this sub-string.

2. If the length of the sub-string is 1, ‘1‘ should be ignored.
 

Input
The first line contains an integer N (1 <= N <= 100) which indicates the number of test cases. The next N lines contain N strings. Each string consists of only ‘A‘ - ‘Z‘ and the length is less than 10000.
 

Output
For each test case, output the encoded string in a line.
 

Sample Input
2 ABC ABBCCC
 

Sample Output
ABC A2B3C
 


如今这题不考英语,不考算法,改考语文了,附张图解释一下题意




技术分享

附ac代码:

#include<string.h>
#include<stdio.h>
char c[10001];
int m,n,t,i,j;
int main()
{
	scanf("%d",&t);
	while(t--)
	{
	scanf("%s",c);
	int l=strlen(c);
	int flag;
	int mark=0;
	while(i<l)
	{
		flag=1;
		for(i=mark;i<l;i++)
		{
			if(c[i+1]==c[i])
			flag++;
			else
			{
			if(flag!=1)
			printf("%d%c",flag,c[i]);
			else
			printf("%c",c[i]);
			break;
			}
		}
		mark=i+1;	
	}
	printf("\n");
	}
	return 0;
}


杭电1020Encoding

标签:put   accept   cas   技术   class   break   lin   following   gre   

原文地址:http://www.cnblogs.com/llguanli/p/6897962.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!