码迷,mamicode.com
首页 > 其他好文 > 详细

POJ 3268 Bookshelf 2 动态规划法题解

时间:2017-05-25 21:54:10      阅读:250      评论:0      收藏:0      [点我收藏+]

标签:inpu   sar   class   not   stdio.h   other   oss   books   ext   

Description

Farmer John recently bought another bookshelf for the cow library, but the shelf is getting filled up quite quickly, and now the only available space is at the top.

FJ has N cows (1 ≤ N ≤ 20) each with some height of Hi (1 ≤ Hi ≤ 1,000,000 - these are very tall cows). The bookshelf has a height of B (1 ≤ B ≤ S, where S is the sum of the heights of all cows).

To reach the top of the bookshelf, one or more of the cows can stand on top of each other in a stack, so that their total height is the sum of each of their individual heights. This total height must be no less than the height of the bookshelf in order for the cows to reach the top.

Since a taller stack of cows than necessary can be dangerous, your job is to find the set of cows that produces a stack of the smallest height possible such that the stack can reach the bookshelf. Your program should print the minimal ‘excess‘ height between the optimal stack of cows and the bookshelf.

Input

* Line 1: Two space-separated integers: N and B
* Lines 2..N+1: Line i+1 contains a single integer: Hi

Output

* Line 1: A single integer representing the (non-negative) difference between the total height of the optimal set of cows and the height of the shelf.

Sample Input

5 16
3
1
3
5
6

Sample Output

1

Source


解题思路:

1 确定可能的最大高度sum。就是全部的cow加起来的高度

2 依据动态规划法。求解1到最大高度sum之间的可能解

3 找到比B(书架高度)的最低高度。可能和B一致。


#include <stdio.h>
#include <vector>
#include <limits.h>
#include <string.h>
#include <algorithm>
using namespace std;

const int MAX_N = 21, MAX_H = 1000000;
int cow[MAX_N];
bool height[MAX_N*MAX_H];

int getMinHeight(int N, int B, int sum)//B < sum
{
	fill(height, height+sum+1, false);
	height[0] = true;
	for (int i = 0; i < N; i++)
	{
		for (int j = sum; j >= cow[i]; j--)
		{
			if (height[j-cow[i]]) height[j] = true;
		}
	}
	int ans = B;
	for (; ans <= sum && !height[ans]; ans++) {}

	return ans;
}

int main()
{
	int N, B, sum;
	while (~scanf("%d %d", &N, &B))
	{
		sum = 0;
		for (int i = 0; i < N; i++)
		{
			scanf("%d", cow+i);
			sum += cow[i];
		}
		printf("%d\n", getMinHeight(N, B, sum)-B);
	}
	return 0;
}




POJ 3268 Bookshelf 2 动态规划法题解

标签:inpu   sar   class   not   stdio.h   other   oss   books   ext   

原文地址:http://www.cnblogs.com/yfceshi/p/6905884.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!