码迷,mamicode.com
首页 > 其他好文 > 详细

Relative atomic mass

时间:2017-06-18 12:03:44      阅读:246      评论:0      收藏:0      [点我收藏+]

标签:each   esc   form   therefore   ace   field   mic   des   ble   

Relative atomic mass

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 617    Accepted Submission(s): 516


Problem Description
Relative atomic mass is a dimensionless physical quantity, the ratio of the average mass of atoms of an element (from a single given sample or source) to 1技术分享2技术分享技术分享技术分享 of the mass of an atom of carbon-12 (known as the unified atomic mass unit).
You need to calculate the relative atomic mass of a molecule, which consists of one or several atoms. In this problem, you only need to process molecules which contain hydrogen atoms, oxygen atoms, and carbon atoms. These three types of atom are written as ’H’,’O’ and ’C’ repectively. For your information, the relative atomic mass of one hydrogen atom is 1, and the relative atomic mass of one oxygen atom is 16 and the relative atomic mass of one carbon atom is 12. A molecule is demonstrated as a string, of which each letter is for an atom. For example, a molecule ’HOH’ contains two hydrogen atoms and one oxygen atom, therefore its relative atomic mass is 18 = 2 * 1 + 16.

 

 

Input
The first line of input contains one integer N(N ≤ 10), the number of molecules. In the next N lines, the i-th line contains a string, describing the i-th molecule. The length of each string would not exceed 10.
 

 

Output
For each molecule, output its relative atomic mass.
 

 

Sample Input
5 H C O HOH CHHHCHHOH
 

 

Sample Output
1 12 16 18 46
 
Source
【思路】模拟
【code】
#include<iostream>
#include<cstdio>
using namespace std;
string s;
int ans,n;
int main()
{
    scanf("%d",&n);
    for(int i=1;i<=n;i++)
    {
        cin>>s;ans=0;
        for(int i=0;i<s.size();i++)
        {
            if(s[i]==C)ans+=12;
            if(s[i]==O)ans+=16;
            if(s[i]==H)ans++;
        }
        printf("%d\n",ans);
     } 
    return 0;
}

 

Relative atomic mass

标签:each   esc   form   therefore   ace   field   mic   des   ble   

原文地址:http://www.cnblogs.com/zzyh/p/7043698.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!