码迷,mamicode.com
首页 > 其他好文 > 详细

Hdu 1062 Text Reverse

时间:2017-06-21 11:26:01      阅读:117      评论:0      收藏:0      [点我收藏+]

标签:getc   lin   class   scan   ++   etc   java   rds   inpu   

Text Reverse

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 30766    Accepted Submission(s): 12153

Problem Description

Ignatius likes to write words in reverse way. Given a single line of text which is written by Ignatius, you should reverse all the words and then output them.

 

 

Input

The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single line with several words. There will be at most 1000 characters in a line.

 

 

Output

For each test case, you should output the text which is processed.

 

 

Sample Input

3

olleh !dlrow

m‘I morf .udh

I ekil .mca

 

 

Sample Output

hello world!

I‘m from hdu.

I like acm.

 

Hint

 

Remember to use getchar() to read ‘\n‘ after the interger T, then you may use gets() to read a line and process it.

#include<stdio.h>int main()
{
    int N;
    char c,a[1010];
    int i;
    while(scanf("%d",&N)!=EOF)
    {
        getchar();
        while(N--)
        {
            i=0;
            while((c=getchar())!=‘\n‘)
            {
                if(c==‘ ‘)
                {
                    while(i--)
                        putchar(a[i]);
                    i=0;
                    printf(" ");
                }
                else
                    a[i++]=c;
            }
            while(i--)
                putchar(a[i]);
            printf("\n");
        }
    }
    return 0;
}

  

Hdu 1062 Text Reverse

标签:getc   lin   class   scan   ++   etc   java   rds   inpu   

原文地址:http://www.cnblogs.com/zhangliu/p/7057841.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!