码迷,mamicode.com
首页 > 其他好文 > 详细

POJ 3258 River Hopscotch 经典二分

时间:2014-05-09 22:12:24      阅读:500      评论:0      收藏:0      [点我收藏+]

标签:des   style   blog   class   code   tar   

River Hopscotch
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 6189   Accepted: 2683

Description

Every year the cows hold an event featuring a peculiar version of hopscotch that involves carefully jumping from rock to rock in a river. The excitement takes place on a long, straight river with a rock at the start and another rock at the end, L units away from the start (1 ≤ L ≤ 1,000,000,000). Along the river between the starting and ending rocks, N (0 ≤ N ≤ 50,000) more rocks appear, each at an integral distance Di from the start (0 < Di <L).

To play the game, each cow in turn starts at the starting rock and tries to reach the finish at the ending rock, jumping only from rock to rock. Of course, less agile cows never make it to the final rock, ending up instead in the river.

Farmer John is proud of his cows and watches this event each year. But as time goes by, he tires of watching the timid cows of the other farmers limp across the short distances between rocks placed too closely together. He plans to remove several rocks in order to increase the shortest distance a cow will have to jump to reach the end. He knows he cannot remove the starting and ending rocks, but he calculates that he has enough resources to remove up to rocks (0 ≤ M ≤ N).

FJ wants to know exactly how much he can increase the shortest distance *before* he starts removing the rocks. Help Farmer John determine the greatest possible shortest distance a cow has to jump after removing the optimal set of M rocks.

Input

Line 1: Three space-separated integers: LN, and M 
Lines 2..N+1: Each line contains a single integer indicating how far some rock is away from the starting rock. No two rocks share the same position.

Output

Line 1: A single integer that is the maximum of the shortest distance a cow has to jump after removing M rocks

Sample Input

25 5 2
2
14
11
21
17

Sample Output

4

Hint

Before removing any rocks, the shortest jump was a jump of 2 from 0 (the start) to 2. After removing the rocks at 2 and 14, the shortest required jump is a jump of 4 (from 17 to 21 or from 21 to 25).

Source


在一条长l的河上有n块石头,已知每块石头距离河的起点距离,现在要求移除m块石头使得相邻两块石头之间的最短距离最大,求此距离。
二分枚举距离k,然后判断移除最大m块石头能否达到k。
//524K	188MS
#include<stdio.h>
#include<algorithm>
#define inf 0x3f3f3f3f
using namespace std;
long long d[50007];
int main()
{
    int n,m,len;
    while(scanf("%d%d%d",&len,&n,&m)!=EOF)
    {
        d[0]=0;//起点
        for(int i=1; i<=n; i++)
            scanf("%lld",&d[i]);
        d[n+1]=len;//终点
        n+=2;
        sort(d,d+n);
        long long l=inf,r=d[n-1],mid;
        for(int i=1; i<n; i++)//求两块石头之间最短距离
            l=min(l,d[i]-d[i-1]);
        while(l<=r)
        {
            mid=(l+r)/2;
            long long s=0,e=1,count=0;
            while(e<n)//枚举所有石头
            {
                if(d[e]-d[s]>=mid)//如果这两块石头的距离大于mid,则不需要移除,更新相邻的石头
                {
                    s=e;
                    e++;
                }
                else//如果这两块石头的距离小于mid,那么需要移除一块石头,count++,然后右面的石头往后移
                {
                    e++;
                    count++;
                }
            }
            if(count>m)r=mid-1;//如果需要移除的石头的数量大于要求的数量,取下限
            else l=mid+1;//否则取上限
        }
        printf("%lld\n",r);
    }
    return 0;
}


POJ 3258 River Hopscotch 经典二分,布布扣,bubuko.com

POJ 3258 River Hopscotch 经典二分

标签:des   style   blog   class   code   tar   

原文地址:http://blog.csdn.net/crescent__moon/article/details/25405915

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!