码迷,mamicode.com
首页 > 其他好文 > 详细

HDU1039 Easier Done Than Said?

时间:2017-07-31 12:34:06      阅读:170      评论:0      收藏:0      [点我收藏+]

标签:orm   rand   job   ble   cep   format   strcmp   rds   sts   

Problem Description

  Password security is a tricky thing. Users prefer simple passwords that are easy to remember (like buddy), but such passwords are often insecure. Some sites use random computer-generated passwords (like xvtpzyo), but users have a hard time remembering them and sometimes leave them written on notes stuck to their computer. One potential solution is to generate "pronounceable" passwords that are relatively secure but still easy to remember.

FnordCom is developing such a password generator. You work in the quality control department, and it‘s your job to test the generator and make sure that the passwords are acceptable. To be acceptable, a password must satisfy these three rules:

It must contain at least one vowel.

It cannot contain three consecutive vowels or three consecutive consonants.

It cannot contain two consecutive occurrences of the same letter, except for ‘ee‘ or ‘oo‘.

(For the purposes of this problem, the vowels are ‘a‘, ‘e‘, ‘i‘, ‘o‘, and ‘u‘; all other letters are consonants.) Note that these rules are not perfect; there are many common/pronounceable words that are not acceptable.
 
  
Input
  The input consists of one or more potential passwords, one per line, followed by a line containing only the word ‘end‘ that signals the end of the file. Each password is at least one and at most twenty letters long and consists only of lowercase letters.
 
  
Output
  For each password, output whether or not it is acceptable, using the precise format shown in the example.
 
  
Sample Input
 

a
tv
ptoui
bontres
zoggax
wiinq
eep
houctuh
end
 
  
Sample Output
 









 
Code:
#include <iostream>
#include <algorithm>
#include <stdio.h>
#include <cstdlib>
#include <cstring>
#include <cmath>
#include <ctime>
#include <ctype.h>


using namespace std;

int judge(char a)
{
        if(a==a||a==e||a==i||a==o||a==u)
            return 1;
    return 0;
}

int main()
{
    char word[20];

    while(scanf("%s",word)!=EOF&&strcmp(word,"end"))
    {
        int l=strlen(word),i,flag=0;

        for(i=0;i<l;i++)
        {
            if(judge(word[i]))
                flag=1;
        }
        if(flag==1)
        {
            for(i=0;i<l-1;i++)
            {
                if(word[i]==word[i+1]&&word[i]!=e&&word[i]!=o)
                {
                    flag=2;
                }
            }

                if(flag==2)
                    printf("<%s> is not acceptable.\n",word);
                else
                {
                    for(i=0;i<l-2;i++)
                    {
                        if((judge(word[i])&&judge(word[i+1])&&judge(word[i+2]))||(!judge(word[i])&&!judge(word[i+1])&&!judge(word[i+2])))
                        {
                            flag=3;
                        }
                    }
                    if(flag==3)
                        printf("<%s> is not acceptable.\n",word);
                    else
                        printf("<%s> is acceptable.\n",word);
                }
        }
        else
            printf("<%s> is not acceptable.\n",word);
    }
    return 0;
}

 

HDU1039 Easier Done Than Said?

标签:orm   rand   job   ble   cep   format   strcmp   rds   sts   

原文地址:http://www.cnblogs.com/gonsedup/p/7262271.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!