码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 4300 Clairewd’s message

时间:2017-08-04 22:54:53      阅读:224      评论:0      收藏:0      [点我收藏+]

标签:UI   color   algo   ever   tchar   tran   nop   sam   line   

Problem Description
Clairewd is a member of FBI. After several years concealing in BUPT, she intercepted some important messages and she was preparing for sending it to ykwd. They had agreed that each letter of these messages would be transfered to another one according to a conversion table.
Unfortunately, GFW(someone‘s name, not what you just think about) has detected their action. He also got their conversion table by some unknown methods before. Clairewd was so clever and vigilant that when she realized that somebody was monitoring their action, she just stopped transmitting messages.
But GFW knows that Clairewd would always firstly send the ciphertext and then plaintext(Note that they won‘t overlap each other). But he doesn‘t know how to separate the text because he has no idea about the whole message. However, he thinks that recovering the shortest possible text is not a hard task for you.
Now GFW will give you the intercepted text and the conversion table. You should help him work out this problem.
 

 

Input
The first line contains only one integer T, which is the number of test cases.
Each test case contains two lines. The first line of each test case is the conversion table S. S[i] is the ith latin letter‘s cryptographic letter. The second line is the intercepted text which has n letters that you should recover. It is possible that the text is complete.
Hint
Range of test data:
T<= 100 ;
n<= 100000;
 

 

Output
For each test case, output one line contains the shorest possible complete text.
 

 

Sample Input
2 abcdefghijklmnopqrstuvwxyz abcdab qwertyuiopasdfghjklzxcvbnm qwertabcde
 

 

Sample Output
abcdabcd qwertabcde
 

 

Author
BUPT
 

 

Source
 
KMP的知识忘得有点厉害了,要赶紧复习一下!
 
#include<cstdio>
#include<algorithm>
#include<cmath>
#include<vector>
#include<queue>
#include<cstring>
#include<iostream>
#include<map>
#define MAXN 100009
#define INF 0x3f3f3f3f
#define eps 1e-11 + 1e-12/2
typedef long long LL;

using namespace std;
/*
字符串匹配!
假设密码文为c1 c2 c3 ..... cn 那么 原文可以设为 f(c1) f(c2) f(c3) f(c4)...f(cn)
f() 的关系给出了!
已知s[]是由一部分 密码文 一部分原文组成的
那么我们可以将截获的密码
c1 c2 c3 ... cn f(c1) f(c2) f(c3)...f(cn)进行一次变换
f(c1) f(c2) f(c3) ......然后找匹配的最长长度,用原串长度减去匹配长度就是密码长度,接下来就好做了!
注意:如果f(f(c1)) == f(c1)怎么办!?
特殊判断一下:如果s[]串和f(s[])串相等,寻求Next[l],匹配的最长前后缀长度,用l-Next[l]就是密码文的长度。
还要注意!密码文的长度至少是n/2!
*/
char s[MAXN], t[MAXN], m[27];
int Next[MAXN];
map<char, char> M;
void kmp_pre(int l)
{
    int j = 0, k = Next[0] = -1;
    while (j < l)
    {
        if (k == -1 || t[j] == t[k])
            Next[++j] = ++k;
        else
            k = Next[k];
    }
}
int KMP(int l)
{
    kmp_pre(l);
    int i, j, ans;
    i = j = ans = 0;
    for (int i = 0; i < l; i++)
    {
        while (j > 0 && s[i] != t[j])
            j = Next[j];
        if (s[i] == t[j])
            j++;
        /*if (j >= l)
        {
            return j - l;
        }*/
    }
    return j;
}
int main()
{
    int T;
    scanf("%d", &T);
    while (T--)
    {
        memset(t, \0, sizeof(t));
        M.clear();
        getchar();
        scanf("%s%s", m, s);
        int lm = strlen(m);
        for (int i = 0; i < lm; i++)
            M[m[i]] = a + i;
        int l = strlen(s);
        if (l == 1)
        {
            printf("%c%c\n", s[0], M[s[0]]);
            continue;
        }
        for (int i = 0; i < l; i++)
            t[i] = M[s[i]];
        if (strcmp(s, t) == 0)
        {
            kmp_pre(l);
            int r = l - Next[l];
            if (l % 2 == 0)
                r = max(l / 2, r);
            else
                r = max(l / 2 + 1, r);
            for (int i = 0; i < r; i++)
                printf("%c", s[i]);
            for (int i = 0; i <r; i++)
                printf("%c", M[s[i]]);
            printf("\n");
            continue;
        }
        int k = KMP(l);
        for (int i = 0; i < l - k; i++)
            printf("%c", s[i]);
        for (int i = 0; i < l - k; i++)
            printf("%c", M[s[i]]);
        printf("\n");
    }
}

 

HDU 4300 Clairewd’s message

标签:UI   color   algo   ever   tchar   tran   nop   sam   line   

原文地址:http://www.cnblogs.com/joeylee97/p/7287170.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!