码迷,mamicode.com
首页 > 其他好文 > 详细

1062. Talent and Virtue (25)

时间:2017-08-11 15:52:52      阅读:208      评论:0      收藏:0      [点我收藏+]

标签:tor   space   scanf   pre   sim   namespace   public   with   pac   

About 900 years ago, a Chinese philosopher Sima Guang wrote a history book in which he talked about people‘s talent and virtue. According to his theory, a man being outstanding in both talent and virtue must be a "sage(圣人)"; being less excellent but with one‘s virtue outweighs talent can be called a "nobleman(君子)"; being good in neither is a "fool man(愚人)"; yet a fool man is better than a "small man(小人)" who prefers talent than virtue.

Now given the grades of talent and virtue of a group of people, you are supposed to rank them according to Sima Guang‘s theory.

Input Specification:

Each input file contains one test case. Each case first gives 3 positive integers in a line: N (<=105), the total number of people to be ranked; L (>=60), the lower bound of the qualified grades -- that is, only the ones whose grades of talent and virtue are both not below this line will be ranked; and H (<100), the higher line of qualification -- that is, those with both grades not below this line are considered as the "sages", and will be ranked in non-increasing order according to their total grades. Those with talent grades below H but virtue grades not are cosidered as the "noblemen", and are also ranked in non-increasing order according to their total grades, but they are listed after the "sages". Those with both grades below H, but with virtue not lower than talent are considered as the "fool men". They are ranked in the same way but after the "noblemen". The rest of people whose grades both pass the L line are ranked after the "fool men".

Then N lines follow, each gives the information of a person in the format:

ID_Number Virtue_Grade Talent_Grade
where ID_Number is an 8-digit number, and both grades are integers in [0, 100]. All the numbers are separated by a space.

Output Specification:

The first line of output must give M (<=N), the total number of people that are actually ranked. Then M lines follow, each gives the information of a person in the same format as the input, according to the ranking rules. If there is a tie of the total grade, they must be ranked with respect to their virtue grades in non-increasing order. If there is still a tie, then output in increasing order of their ID‘s.

Sample Input:
14 60 80
10000001 64 90
10000002 90 60
10000011 85 80
10000003 85 80
10000004 80 85
10000005 82 77
10000006 83 76
10000007 90 78
10000008 75 79
10000009 59 90
10000010 88 45
10000012 80 100
10000013 90 99
10000014 66 60
Sample Output:
12
10000013 90 99
10000012 80 100
10000003 85 80
10000011 85 80
10000004 80 85
10000007 90 78
10000006 83 76
10000005 82 77
10000002 90 60
10000014 66 60
10000008 75 79
10000001 64 90


提前分类,然后来个快排。

代码:


#include <iostream>
#include <cstdlib>
#include <algorithm>
#include <cstdio>
using namespace std;
class people
{
public:
    int ID_Number;
    int Virtue_Grade;
    int Talent_Grade;
    int Sum_Grade;
    int Grade_Class;
}p[100000];
bool cmp(people a,people b)
{
    if(a.Grade_Class==b.Grade_Class)
    {
        if(a.Sum_Grade==b.Sum_Grade)
        {
            if(a.Virtue_Grade==b.Virtue_Grade)return a.ID_Number<b.ID_Number;
            return a.Virtue_Grade>b.Virtue_Grade;
        }
        return a.Sum_Grade>b.Sum_Grade;
    }
    return a.Grade_Class<b.Grade_Class;
}
int main()
{
    int N,L,H;
    scanf("%d%d%d",&N,&L,&H);
    for(int i=0;i<N;i++)
    {
        scanf("%d%d%d",&p[i].ID_Number,&p[i].Virtue_Grade,&p[i].Talent_Grade);
        p[i].Sum_Grade=p[i].Virtue_Grade+p[i].Talent_Grade;
        if(p[i].Virtue_Grade<L||p[i].Talent_Grade<L)i--,N--;
        else if(p[i].Virtue_Grade>=H&&p[i].Talent_Grade>=H)p[i].Grade_Class=1;
        else if(p[i].Virtue_Grade>=H)p[i].Grade_Class=2;
        else if(p[i].Virtue_Grade<H&&p[i].Virtue_Grade>=p[i].Talent_Grade)p[i].Grade_Class=3;
        else p[i].Grade_Class=4;
    }
    sort(p,p+N,cmp);
    printf("%d\n",N);
    for(int i=0;i<N;i++)
        printf("%d %d %d\n",p[i].ID_Number,p[i].Virtue_Grade,p[i].Talent_Grade);
}

 

1062. Talent and Virtue (25)

标签:tor   space   scanf   pre   sim   namespace   public   with   pac   

原文地址:http://www.cnblogs.com/8023spz/p/7345984.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!