码迷,mamicode.com
首页 > 其他好文 > 详细

poj 3624 Charm Bracelet

时间:2017-08-26 10:12:27      阅读:187      评论:0      收藏:0      [点我收藏+]

标签:ble   plm   span   center   desc   ack   const   cst   iostream   

                                                                          Charm Bracelet
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 41106   Accepted: 17884

Description

Bessie has gone to the mall‘s jewelry store and spies a charm bracelet. Of course, she‘d like to fill it with the best charms possible from the N (1 ≤ N ≤ 3,402) available charms. Each charm i in the supplied list has a weight Wi (1 ≤ Wi≤ 400), a ‘desirability‘ factor Di (1 ≤ Di ≤ 100), and can be used at most once. Bessie can only support a charm bracelet whose weight is no more than M (1 ≤ M ≤ 12,880).

Given that weight limit as a constraint and a list of the charms with their weights and desirability rating, deduce the maximum possible sum of ratings.

Input

* Line 1: Two space-separated integers: N and M
* Lines 2..N+1: Line i+1 describes charm i with two space-separated integers: Wi and Di

Output

* Line 1: A single integer that is the greatest sum of charm desirabilities that can be achieved given the weight constraints

Sample Input

4 6
1 4
2 6
3 12
2 7

Sample Output

23

Source

思路:01背包裸题。
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int n,m,w[3500],d[3500],f[13000];
int main(){
    scanf("%d%d",&n,&m);
    for(int i=1;i<=n;i++)
        scanf("%d%d",&w[i],&d[i]);
    for(int i=1;i<=n;i++)
        for(int j=m;j>=w[i];j--)
            f[j]=max(f[j],f[j-w[i]]+d[i]);
    printf("%d",f[m]);
} 

 

poj 3624 Charm Bracelet

标签:ble   plm   span   center   desc   ack   const   cst   iostream   

原文地址:http://www.cnblogs.com/cangT-Tlan/p/7434464.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!