码迷,mamicode.com
首页 > 其他好文 > 详细

hdu 3371 Connect the Cities

时间:2014-05-10 07:33:38      阅读:265      评论:0      收藏:0      [点我收藏+]

标签:des   style   blog   class   code   java   

Problem Description
In 2100, since the sea level rise, most of the cities disappear. Though some survived cities are still connected with others, but most of them become disconnected. The government wants to build some roads to connect all of these cities again, but they don’t want to take too much money.  
 

 

Input
The first line contains the number of test cases.
Each test case starts with three integers: n, m and k. n (3 <= n <=500) stands for the number of survived cities, m (0 <= m <= 25000) stands for the number of roads you can choose to connect the cities and k (0 <= k <= 100) stands for the number of still connected cities.
To make it easy, the cities are signed from 1 to n.
Then follow m lines, each contains three integers p, q and c (0 <= c <= 1000), means it takes c to connect p and q.
Then follow k lines, each line starts with an integer t (2 <= t <= n) stands for the number of this connected cities. Then t integers follow stands for the id of these cities.
 

 

Output
For each case, output the least money you need to take, if it’s impossible, just output -1.
 

 

Sample Input
1
6 4 3
1 4 2
2 6 1
2 3 5
3 4 3 3
2 1 2
2 1 3
3 4 5 6
 

 

Sample Output
1

 这个题数据真的有点大,我的程序跑了953ms,差一点超时啊

bubuko.com,布布扣
#include<iostream>
#include<cstdio>
#include<vector>
#include<algorithm>
using namespace std;
const int MAX=1000000;
struct node
{
    int left,right,cost;
}road[MAX];

bool cmp(node x,node y){return x.cost<y.cost;}

int p[MAX],m,n;

int find(int x){return x==p[x]? x:p[x]=find(p[x]);}

int kruskal()
{
    int ans=0,k=0;
    for (int i=0;i<=n;i++) p[i]=i;
    for (int i=0;i<m;i++)
    {
        int x=find(road[i].left);
        int y=find(road[i].right);
        if(x!=y)
        {
            ans+=road[i].cost;
            p[x]=y;
            k++;
        }
        if (k==n-1) break;
    }
    if (k==n-1)return ans;
    else return -1;
}

int main()
{
    int x,y,c,k,num,a[500],T;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d%d%d",&n,&m,&k);
        for (int i=0;i<m;i++)
        scanf("%d%d%d",&road[i].left,&road[i].right,&road[i].cost);
        while(k--)
        {
            scanf("%d",&num);
            for (int i=0;i<num;i++) {
                scanf("%d",&a[i]);
                for (int j=0;j<i;j++)
                {
                    road[m].left=a[i];
                    road[m].right=a[j];
                    road[m].cost=0;
                    m++;
                }
            }
        }
        sort(road,road+m,cmp);
        int mintree=kruskal();
        printf("%d\n",mintree);
    }
    return 0;
}
bubuko.com,布布扣

 

hdu 3371 Connect the Cities,布布扣,bubuko.com

hdu 3371 Connect the Cities

标签:des   style   blog   class   code   java   

原文地址:http://www.cnblogs.com/chensunrise/p/3719856.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!