码迷,mamicode.com
首页 > 其他好文 > 详细

Uva679 Dropping Balls

时间:2017-09-21 22:25:47      阅读:191      评论:0      收藏:0      [点我收藏+]

标签:i+1   ble   ima   tree   contain   tin   play   idt   turn   

A number of K balls are dropped one by one from the root of a fully binary tree structure FBT. Each time the ball being dropped first visits a non-terminal node. It then keeps moving down, either follows the path of the left subtree, or follows the path of the right subtree, until it stops at one of the leaf nodes of FBT. To determine a ball‘s moving direction a flag is set up in every non-terminal node with two values, either false or true. Initially, all of the flags are false. When visiting a non-terminal node if the flag‘s current value at this node is false, then the ball will first switch this flag‘s value, i.e., from the false to the true, and then follow the left subtree of this node to keep moving down. Otherwise, it will also switch this flag‘s value, i.e., from the true to the false, but will follow the right subtree of this node to keep moving down. Furthermore, all nodes of FBT are sequentially numbered, starting at 1 with nodes on depth 1, and then those on depth 2, and so on. Nodes on any depth are numbered from left to right.

 


For example, Fig. 1 represents a fully binary tree of maximum depth 4 with the node numbers 1, 2, 3, ..., 15. Since all of the flags are initially set to be false, the first ball being dropped will switch flag‘s values at node 1, node 2, and node 4 before it finally stops at position 8. The second ball being dropped will switch flag‘s values at node 1, node 3, and node 6, and stop at position 12. Obviously, the third ball being dropped will switch flag‘s values at node 1, node 2, and node 5 before it stops at position 10.

 

技术分享

 


Fig. 1: An example of FBT with the maximum depth 4 and sequential node numbers.

 

 


Now consider a number of test cases where two values will be given for each test. The first value is D, the maximum depth of FBT, and the second one is I, the Ith ball being dropped. You may assume the value of I will not exceed the total number of leaf nodes for the given FBT.

Please write a program to determine the stop position P for each test case.

 


For each test cases the range of two parameters D and I is as below: 

 

技术分享

 

 

 

Input 

Contains l+2 lines.

 Line 1 I the number of test cases 
Line 2 技术分享 test case #1, two decimal numbers that are separatedby one blank 
... 		 		 
Line k+1 技术分享 test case #k Line l+1 技术分享 test case #l Line l+2 -1 a constant -1 representing the end of the input file 

 

Output 

Contains l lines.

 Line 1 		 the stop position P for the test case #1 
... 		 
Line k the stop position P for the test case #k 
... 		 
Line l the stop position P for the test case #l

 

Sample Input 

 

5
4 2
3 4
10 1
2 2
8 128
-1

 

Sample Output 

12
7
512
3
255
题目大意:给你一个D层深的树,I个小球,每个小球从根节点开始走,一开始向左走,以后的球走到这个点都走与前一个到这个点的球的相反的方向,求最后每个球的位置编号.
分析:一开始看着是一道很水的模拟题,直接模拟一下每次怎么走,判判方向就好了,可是由于数据量太大了,会超时。
其实很容易就能发现规律了,每个球到当前点的方向取决于它是第几个到这个点的,如果是奇数,就往左边走,否则就往右边走,那么我们直接处理最后一个球就好了,那么如果走左子树,那么它就是第(I+1)/2个到达的,否则就是I/2个到达的。
#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>
#include <cmath>

using namespace std;

int T,D,I,res = 1;

int main()
{
    scanf("%d", &T);
    while (T--)
    {
        res = 1;
        scanf("%d%d", &D, &I);
        for (int i = 1; i <= D - 1; i++)
        {
            if (I % 2 == 1)
            {
                res *= 2;
                I = (I + 1) / 2;
            }
            else
            {
                res = res * 2 + 1;
                I /= 2;
            }
        }
        printf("%d\n", res);
    }

    return 0;
}

 

 

Uva679 Dropping Balls

标签:i+1   ble   ima   tree   contain   tin   play   idt   turn   

原文地址:http://www.cnblogs.com/zbtrs/p/7571479.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!