码迷,mamicode.com
首页 > 其他好文 > 详细

[最小表示] zoj 1729 Hidden Password

时间:2014-05-11 01:52:41      阅读:367      评论:0      收藏:0      [点我收藏+]

标签:des   style   blog   class   code   tar   

题目链接:

http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemId=729

Hidden Password

Time Limit: 2 Seconds      Memory Limit: 65536 KB

Some time the programmers have very strange ways to hide their passwords. See for example how Billy "Hacker" Geits hide his password. Billy chooses a string S composed of small Latin letters with length L. Then he makes all L-1 one-letter left cyclic shifts of the string and takes as a password one prefix of the lexicographically first of the obtained strings (including S). For example let consider the string alabala. The cyclic one-letter left shifts (including the initial string) are:

alabala
labalaa
abalaal
balaala
alaalab
laalaba
aalabal

and lexicographically first of them is the string aalabal. The first letter of this string is in position 6 in the initial string (the positions in the string are counted from 0).

Write a program that for given string S finds the start position of the smallest lexicographically one-letter left cyclic shift of this string. If the smallest lexicographically left shift appears more than once then the program have to output the smallest initial position.

Your program has to be ready to solve more than one test case. The first line of the input file will contains only the number T of the test cases. Each of the following T lines will describe one test case - first the length L of the string (5 <= L <= 100000) and then, separated by one space, the string S itself.

The output file have to contain exactly T lines with a single number each - the initial position found by your program.


Sample Input

2
6 baabaa
7 alabala


Sample Output

1
6


Source: Southeastern Europe 2003
Submit    Status

题目意思:

求每个串的字典序最小的循环串。

解题思路:

最小表示法。

代码:

//#include<CSpreadSheet.h>

#include<iostream>
#include<cmath>
#include<cstdio>
#include<sstream>
#include<cstdlib>
#include<string>
#include<string.h>
#include<cstring>
#include<algorithm>
#include<vector>
#include<map>
#include<set>
#include<stack>
#include<list>
#include<queue>
#include<ctime>
#include<bitset>
#include<cmath>
#define eps 1e-6
#define INF 0x3f3f3f3f
#define PI acos(-1.0)
#define ll __int64
#define LL long long
#define lson l,m,(rt<<1)
#define rson m+1,r,(rt<<1)|1
#define M 1000000007
//#pragma comment(linker, "/STACK:1024000000,1024000000")
using namespace std;

#define Maxn 110000

char save[Maxn];
int n;

int cal()
{
    int i=0,j=1;

    while(i<n&&j<n)
    {
        int k=0;
        while(k<n&&save[(i+k)%n]==save[(j+k)%n])
            k++;
        if(k>=n)
            break;
        if(save[(i+k)%n]>save[(j+k)%n])
        {
            i=i+k+1;
            if(i==j)
                i++;
        }
        else
        {
            j=j+k+1;
            if(i==j)
                i++;
        }
    }
    return min(i,j);
}

int main()
{
   //freopen("in.txt","r",stdin);
   //freopen("out.txt","w",stdout);
   int t;

   scanf("%d",&t);
   while(t--)
   {
       scanf("%d%s",&n,save);
       printf("%d\n",cal());
   }
   return 0;
}




[最小表示] zoj 1729 Hidden Password,布布扣,bubuko.com

[最小表示] zoj 1729 Hidden Password

标签:des   style   blog   class   code   tar   

原文地址:http://blog.csdn.net/cc_again/article/details/25504929

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!