码迷,mamicode.com
首页 > 其他好文 > 详细

Hangover

时间:2014-05-12 01:43:46      阅读:233      评论:0      收藏:0      [点我收藏+]

标签:des   style   blog   class   code   java   

POJ - 1003
         

 

Description

How far can you make a stack of cards overhang a table? If you have one card, you can create a maximum overhang of half a card length. (We‘re assuming that the cards must be perpendicular to the table.) With two cards you can make the top card overhang the bottom one by half a card length, and the bottom one overhang the table by a third of a card length, for a total maximum overhang of 1/2 + 1/3 = 5/6 card lengths. In general you can make n cards overhang by 1/2 + 1/3 + 1/4 + ... + 1/(n + 1) card lengths, where the top card overhangs the second by 1/2, the second overhangs tha third by 1/3, the third overhangs the fourth by 1/4, etc., and the bottom card overhangs the table by 1/(n + 1). This is illustrated in the figure below.

bubuko.com,布布扣

Input

The input consists of one or more test cases, followed by a line containing the number 0.00 that signals the end of the input. Each test case is a single line containing a positive floating-point number c whose value is at least 0.01 and at most 5.20; c will contain exactly three digits.

Output

For each test case, output the minimum number of cards necessary to achieve an overhang of at least c card lengths. Use the exact output format shown in the examples.

Sample Input

1.00
3.71
0.04
5.19
0.00

Sample Output

3 card(s)
61 card(s)
1 card(s)
273 card(s)

 

bubuko.com,布布扣
方法-:

#include<stdio.h>
int main(){
    float x;
    while(scanf("%f",&x)==1){
        int i;
        float t=0.0;
        if(x==0.00) break;
        for(i=1;t<x;i++)  t+=1.0/(float)(i+1);                                     
        printf("%d card(s)\n",i-1);
    }
}



方法二:


#include<stdio.h>
int main(){
    int n;
    float b;
    for(;n=scanf("%f",&b),b;printf("%d card(s)\n",n-1))
        for(;b>0;b-=1./++n);
}
bubuko.com,布布扣

 

Hangover,布布扣,bubuko.com

Hangover

标签:des   style   blog   class   code   java   

原文地址:http://www.cnblogs.com/HRuinger/p/3721410.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!